Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Originally Posted by white_hound If it booted well with a particular type of flash, implies it might not boot so well with another. I know I repeat the same mantra ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Aug 2012
    Posts
    39

    Quote Originally Posted by white_hound View Post
    If it booted well with a particular type of flash, implies it might not boot so well with another. I know I repeat the same mantra all the time - chances you don't mount the root fs.
    I found by accident on old file system image that I had built, which my kernel can mount. Something that intrigues me is when I look at the folder which is turned into the flash image on my development system, the /sys folder is empty, but when on my application board when I view the folder the it has several items in it such as block, class, firmware and several others. I was under the impression that when I built my kernel that the directory containing the files for the filesystem image would be filled out. Should this be the case? And if this is not happening would this be the reason that I'm running into problems?

  2. #12
    Just Joined!
    Join Date
    Jun 2006
    Posts
    57
    No.
    /sys/ is a virtual filesystem. It is built in runtime by the kernel and represents the current kernel state. In other words, the information in /sys is only _represented_ as files, whereas it is not present on some kind of physical medium.
    So what you see is Ok.
    Take into account, that there are additional virtual filesystems (/proc, /dev, one can mount a compressed file ...), and there might exist empty folders that will be used for mounting other physical filesystems (the most popular is /mnt).

  3. #13
    Just Joined!
    Join Date
    Aug 2012
    Posts
    39
    Hi,

    I have managed to resolve the issue, although I'm not entirely sure what I did to mess things up in the first place.

    When I tried to restore the file system image initially I decompressed the tarball on my windows system and then copied it to the Linux development system. When I un tared the filesystem image on the linux system, the problem was solved.

    I found this solution by accident, someone mentioned about that fact that they have had problems copying from one file system type to another, which appears to be true in this case.

    Andrew

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jun 2006
    Posts
    57
    Yeah, great !
    Sounds reasonable - 'init' exists, but has no execution permission.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •