Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    compileing a new Linux kernel


    I am trying to compile a kernel : linux-3.2.31
    1. make oldconfig
    2. make
    The first stage (bzImage) finished ok .
    The 2nd stage (modules) failed with the following :
    BUILD arch/x86/boot/bzImage
    Setup is 16876 bytes (padded to 16896 bytes).
    System is 3847 kB
    CRC 12b91178
    Kernel: arch/x86/boot/bzImage is ready (#2)
    Building modules, stage 2.
    MODPOST 2212 modules
    ERROR: "smp_conn_security" [net/bluetooth/bluetooth.ko] undefined!
    make[1]: *** [__modpost] Error 1
    make: *** [modules] Error 2

    the undefined code exists and I do not see there any #ifdef dependency on a FLAG in the .config

    Any idea ?

  2. #2
    Hello
    This is interesting because i got 3.2.30 and working good but 3.2.31 crash this same like You:
    ERROR: "smp_conn_security" [net/bluetooth/bluetooth.ko] undefined!
    make[1]: *** [__modpost] error 1
    make: *** [modules] error 2

    Looks like bug in stable kernel...

  3. #3
    Just to throw my hat into the ring, I am also getting this compile failure in the same place with 3.2.31. Compiling 3.2.30 works with no issues using gcc 4.4.3 on an Ubuntu 10.04 32-bit system. Definitely smells like a bug to me.

  4. $spacer_open
    $spacer_close
  5. #4
    with appropriate .config this kernel version can be build to the end

    SOLVED
    Last edited by dubi; 10-16-2012 at 04:16 PM.

  6. #5
    Quote Originally Posted by dubi View Post
    with appropriate .config this kernel version can be build to the end

    SOLVED
    Okay, that's lovely - but a little more information would be nice. It's obvious that myself and others are missing something here and some detail as to what we have wrong in our kernel config files would be very handy!

  7. #6
    Hi,

    looks like CONFIG_BT_L2CA needs to be set. Here's part of my config:

    CONFIG_BT=m
    CONFIG_BT_L2CAP=y
    CONFIG_BT_SCO=y
    CONFIG_BT_RFCOMM=m
    CONFIG_BT_RFCOMM_TTY=y
    # CONFIG_BT_BNEP is not set
    CONFIG_BT_CMTP=m
    CONFIG_BT_HIDP=m

    Modules build ok after that.

  8. #7
    Quote Originally Posted by can17 View Post
    Hi,

    looks like CONFIG_BT_L2CA needs to be set. Here's part of my config:

    CONFIG_BT=m
    CONFIG_BT_L2CAP=y
    CONFIG_BT_SCO=y
    CONFIG_BT_RFCOMM=m
    CONFIG_BT_RFCOMM_TTY=y
    # CONFIG_BT_BNEP is not set
    CONFIG_BT_CMTP=m
    CONFIG_BT_HIDP=m

    Modules build ok after that.
    Works for me! Thank you - much appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •