Find the answer to your Linux question:
Results 1 to 10 of 10
Hi, I am trying to configure kernel with USB host with FTDI USB serial driver. It seems that I am not doing it well since when I am connecting the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    8

    MPC8308RDB kernel: support USB serial


    Hi,

    I am trying to configure kernel with USB host with FTDI USB serial driver.
    It seems that I am not doing it well since when I am connecting the device nothing is hapenning.
    I am using kernel version 3.5

    Please advise

    Thanks

    Avner

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hi,

    What do you expect to be happening? I.e., have you looked in the output of dmesg for kernel activity, when connecting a device?


    Also, look for these devices:

    Code:
    ls -l /dev/ttyUSB*

  3. #3
    Just Joined!
    Join Date
    Jul 2012
    Posts
    8
    This id the problem - nothing is happening
    I am expecting for some indication when I am connecting my USB device (FTDI)
    I added manually ttyUSB devices - but it doesn't work.
    Is there anywhere kernel config file for configuring USB Host with serial for MPC8308?
    I also need an example of the .dts file for such configuration (for MPC8308_RDB)

    Thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by aflesch View Post
    This id the problem - nothing is happening
    I am expecting for some indication when I am connecting my USB device (FTDI)
    Just trying to be clear: there is no indication in dmesg?

    I added manually ttyUSB devices - but it doesn't work.
    How did you add these devices, using mknod?
    Can you show the command(s) you used to create the devices?

    Is there anywhere kernel config file for configuring USB Host with serial for MPC8308?
    In kernel 3.4.4-5, I see the FTDI support here:
    Code:
    Device Drivers --->
      USB Support --->
        USB Serial Converter Support --->
          USB FTDI Single Port Serial Driver
    Of course, you'll also need basic serial device support:
    Code:
    Device Drivers --->
      Character Devices --->
        Serial Drivers --->
    I also need an example of the .dts file for such configuration (for MPC8308_RDB)
    Sorry, don't know what you mean here.

  6. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    8
    Just trying to be clear: there is no indication in dmesg?
    No

    How did you add these devices, using mknod?
    Can you show the command(s) you used to create the devices?
    Code:
    mknod /dev/ttyUSB0 c 188 0
    In kernel 3.4.4-5, I see the FTDI support here:
    ...
    Of course, you'll also need basic serial device support:
    I checked them both - and more: USB Host, EHCI modes
    But I guess I did something wrong

    .dts file is data tree - it represent the busses and periphrials - Freescale PQ kerenel support it

    Let ask this way - Afetr I am booting with kernel tht was built with the correct USB Host - serial configuration should it identify my USB device? should I do something in the userspace?
    Is there a way to debug it?

    Thanks

    Avner

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by aflesch View Post
    Code:
    mknod /dev/ttyUSB0 c 188 0
    That looks right.

    I checked them both - and more: USB Host, EHCI modes
    But I guess I did something wrong
    Did u build them as modules are built-ins?

    .dts file is data tree - it represent the busses and periphrials - Freescale PQ kerenel support it
    I can't speak to that at all...

    Let ask this way - Afetr I am booting with kernel tht was built with the correct USB Host - serial configuration should it identify my USB device? should I do something in the userspace?
    I would boot up with the USB device not plugged in. then once it is up, plug in the USB device, and then you should see activity in dmesg. Clearly you are not, though. If you've built the driver as a module, try inserting it manually:

    Code:
    modprobe ftdi_sio
    I'm not sure if that is the right driver name, though. Look for it in
    Code:
    /lib/modules/$(uname -r)/
    Is there a way to debug it?
    according to the modinfo of that driver, you can pass to it a debug parameter:

    Code:
    modinfo /lib/modules/3.3.7-1.fc17.i686.PAE/kernel/drivers/usb/serial/ftdi_sio.ko|grep parm

  8. #7
    Just Joined!
    Join Date
    Jul 2012
    Posts
    8
    Did u build them as modules are built-ins?
    It is built-in? Shoul I build it as a modules?

  9. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by aflesch View Post
    It is built-in? Shoul I build it as a modules?
    Sorry, I should have said, "Did u build them as modules or built-in?". By default, they are built as modules, which is easier for trouble-shooting purposes. But they have to be manually loaded sometimes.

  10. #9
    Just Joined!
    Join Date
    Jul 2012
    Posts
    8
    I managed to solve this issue: I wrote a post on this on my Blog (google blogs)
    But I still not allowed to insert links

    Thanks

  11. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    URL with solution posted on behalf of aflesch:

    http://avnerf.blogspot.co.il/

    Locking thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •