Find the answer to your Linux question:
Results 1 to 3 of 3
I am fairly new to the linux kernel, but I have been working on porting a modified kernel 2.6.29 to another ARM chip ( cortex A-8 ). I got it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2012
    Posts
    2

    Root File System issue


    I am fairly new to the linux kernel, but I have been working on porting a modified kernel 2.6.29 to another ARM chip ( cortex A-8 ). I got it to boot to a point at which it was asking for a root file system. I then built a basic file system using busybox. I then tried to boot the kernel using the following configurations:

    BLK_DEV_INITRD=y
    INITRAMFS_SOURCE=myinitfs.cpio.gz
    BLK_DEV_RAM_COUNT=1
    BLK_DEV_RAM_SIZE=8192

    Boot args: console=ttyS0,115200n8

    Using gdb, I can determine that it is crashing somewhere within inflate_codes after going through these calls:

    populate_rootfs->unpack_to_rootfs->gunzip->inflate->inflate_block->inflate_dynamic->inflate_codes

    I also tried making another rootfs using buildroot, which gave me a larger initramfs. What was interesting was that the larger build called inflate_dynamic about 11 times before it crashed, while the smaller one called it 2 times before it crashed. This makes it seem like it is crashing while unzipping the end of the initramfs.

    I would post my log output, but this crash occurs before the serial initialization, so I have no output.

    Anything pointing me in the right direction would be helpful. inflate_codes is full of loops, so it is incredibly hard to step through to figure out exactly where it is failing.

    Thanks

  2. #2
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    Location
    3rd rock from sun - Often seen near moon
    Posts
    1,758
    I don't have answer this and also I'm not sure about others too. If you didn't get answer here , drop a mail to MailingList - Linux Kernel Newbies .
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    -----
    FOSS India Award winning ext3fs Undelete tool www.giis.co.in. Online Linux Terminal http://www.webminal.org

  3. #3
    Just Joined!
    Join Date
    Dec 2012
    Posts
    2
    I tried using a very small junk file, 8KB uncompressed, as the root fs and the kernel was able to unzip it. The actual busybox fs I am trying to use has a size of about 2MB uncompressed and 1.1MB compressed. This makes it seem like some sort of configuration of size issue. The only related configuration I can find is the BLK_DEV_RAM_SIZE and 8192 KB should be enough.

    Is there another configuration, maybe a boot option?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •