Find the answer to your Linux question:
Results 1 to 4 of 4
Ever since 3.7.4 I have not been able to successfully build the linux kernel due to the error given at the end of this post, do any of you have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3

    Cannot build kernel since 3.7.4


    Ever since 3.7.4 I have not been able to successfully build the linux kernel due to the error given at the end of this post, do any of you have suggestions on what I can do to resolve this issue?

    If it helps here's a few seemingly relevant kernel configs (which matches my current configuration for 3.7.3), if you'd like to see more let me know:
    Code:
    # CONFIG_PCI is not set
    CONFIG_PCI_LABEL=y
    CONFIG_GENERIC_PCI_IOMAP=y
    In addition to those configs, it may help for me to mention that I'm running this kernel within a Xen VPS hosted on Linode. For that these extra configs are also set, at a high level (omitting extra virt/xen configs):
    Code:
    CONFIG_PARAVIRT=y
    CONFIG_VIRT_TO_BUS=y
    CONFIG_VIRTUALIZATION=y
    CONFIG_XEN=y
    CONFIG_XEN_BLKDEV_FRONTEND=y
    CONFIG_XEN_NETDEV_FRONTEND=y
    CONFIG_INPUT_XEN_KBDDEV_FRONTEND=y
    CONFIG_HVC_XEN=y

    Finally, here is the build error:
    Code:
      GEN     .version
      CHK     include/generated/compile.h
      UPD     include/generated/compile.h
      CC      init/version.o
      LD      init/built-in.o
    arch/x86/built-in.o: In function `setup_arch':
    (.init.text+0x2f8d): undefined reference to `early_pci_allowed'
    arch/x86/built-in.o: In function `setup_arch':
    (.init.text+0x2fa1): undefined reference to `read_pci_config_16'
    arch/x86/built-in.o: In function `setup_arch':
    (.init.text+0x2fba): undefined reference to `read_pci_config_16'
    make: *** [vmlinux] Error 1

    I can currently build and am running 3.7.3.
    Last edited by lostmahmind; 01-29-2013 at 05:04 PM. Reason: supplimental information

  2. #2
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    While not sure why are you getting this error ... have you tried make mproper and starting from scratch without merging with make oldconfig?

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    I almost always make mrproper before building, and while I do typically make oldconfig, in this instance I also have tried a make menuconfig and still ran into the issue.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    OK, the problem is that in fact PCI must now be enabled if virtualization is (or at least that seems to be the case).

    I wonder why all of a sudden PCI is required...

    Thanks anyway,
    Last edited by lostmahmind; 01-30-2013 at 12:23 AM. Reason: type-o

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •