Find the answer to your Linux question:
Results 1 to 4 of 4
A little background : This is my first endeavor into the world of Linux. I presently use VMware with the latest Fedora. I have an Android phone from China that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2013
    Posts
    3

    Question On Make get "fatal error: fuse.h", not sure how to get around this?


    A little background: This is my first endeavor into the world of Linux. I presently use VMware with the latest Fedora. I have an Android phone from China that no one has made a custom kernel for. So, I thought I would try my hand which has led me here.

    The Issue: I am ready to compile my kernel so I type in "Make" and let it fly. I corrected my first error, which was "SMC #0" for a sleep.S file. But now I run into the following:

    Code:
    arch/arm/mach-tegra/usb_phy.c:35:18: fatal error: fuse.h: No such file or directory
    compilation terminated.
    I went to the directory specified and found the usb_phy.c file, and it does reference the fuse.h file. That file is in the same directory, so I am unsure what the issue could be or what to do next...

    Any suggestions or advice would be much appreciated!

  2. #2
    Just Joined!
    Join Date
    Sep 2013
    Posts
    3
    I wasn't sure what to do, so I tried the only thing that I thought would get me passed this error. I deleted the single reference to the fuse.h file.

    Now there's another issue:

    TIMEC kernel/timeconst.h
    /bin/sh: perl: command not found
    make[1]: *** [kernel/tomeconst.h] Error 127
    make: *** [kernel] Error 2

    I thought maybe because perl wasn't installed, so I used "sudo yum install perl" to do so and repeat the compilation process, but I still get this error...

    Any ideas on what to do? Thanks!

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    Kernel modules include other headers because their services are required. Compiling a new Android kernel is not trivial, and if you are new to this, then you have a long way to go before you are ready to build one in this environment... Start reading the Android developer documentation, and the Linux kernel documentation, and then make sure that you are trying to build a compatible kernel. Also, since Android mostly runs on ARM processors, if your build system is an x86 PC, you will need the appropriate cross-compilation tool chain - compilers, linkers, libraries, etc.

    FWIW, I build ARM kernels on my x86 Linux workstation (running Scientific Linux - a Red Hat Enterprise Linux clone) and laptop, with the appropriate tool chain. I even taught a mini-class to a group of IEEE engineers on how to do this to build embedded Linux systems on ARM processors. In the class, we made some kernel changes, rebuilt the kernel, and then booted and ran it to verify that it worked properly (it did). Since Android is a Linux version, it should be much the same, but you will need to install it appropriately after building.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Just Joined!
    Join Date
    Sep 2013
    Posts
    3
    I appreciate the reply, although I don't find it immediately helpful.

    I actually did not just pick this up, as I would not know where to begin. I followed a YouTube tutorial initially, from a guy that seemed to have a lot of knowledge in Linux. I got close with his, but fell short at the end (no image). This happened to be my second attempt, this time with a written tutorial.

    There are certainly reasons I have come up with that may allude to what the problems truly are, but I do not have the understanding to back them up.

    I am actually going to try a third tutorial I found and try my luck there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •