Find the answer to your Linux question:
Results 1 to 6 of 6
Hi. I'm using kernel linux 3.11.9 on Xilinx ML605 with Microblaze processor. I have problem to write a file of 40 MB dimension. When i use the command dd the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3

    Problem with kernel 3.11.9


    Hi.
    I'm using kernel linux 3.11.9 on Xilinx ML605 with Microblaze processor.
    I have problem to write a file of 40 MB dimension.
    When i use the command dd the kernel crashes with this error:

    dd if=/dev/zero of=/mnt/foobar count=1024 bs=40000
    BUG: failure at fs/buffer.c:1966/__block_commit_write()!
    Kernel panic - not syncing: BUG!
    Oops: kernel access of bad area, sig: 11
    CPU: 0 PID: 85 Comm: dd Not tainted 3.11.8 #1
    task: ce4d0ba0 ti: ce4e2000 task.ti: ce4e2000
    Registers dump: mode=CE4E362C
    r1=C00FC118, r2=00000000, r3=0000001C, r4=C0C4CA14
    r5=C05BA3BC, r6=00000038, r7=C05BA4AC, r8=C0C4CA14
    r9=00200200, r10=00000000, r11=00000000, r12=00001D70
    r13=00000000, r14=C03E4E0C, r15=C02E6D08, r16=00000000
    r17=C02E6C88, r18=00200200, r19=C0C4CA00, r20=4825AFF4
    r21=00000000, r22=C0C4CA14, r23=0000054F, r24=C0C9E9C0
    r25=0000054E, r26=00000000, r27=C06D2390, r28=00000001
    r29=0000000E, r30=C0CB6240, r31=CE4D0BA0, rPC=C02E6C88
    msr=000046A0, ear=00000000, esr=00000872, fsr=CE4E36BC
    Kernel panic - not syncing: Aiee, killing interrupt handler!


    Can anyone help me?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,978
    Update the kernel? Actually, you may be overrunning the kernel's I/O write buffer. You are writing 1024 blocks of 40000 bytes. That == 40MB approximately, and since this is an embedded system (I assume), you may not have enough memory allocated to the kernel to deal with that. What happens of you reduce the memory required by dd, such as using 4000 byte block sizes, or fewer blocks?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    Thaks for the replay.
    The version 3.11.9 is updated at 2013-11-20.
    I using this kernel on an embedded system with Microblaze processor, 256MB DDR2 RAM and a filesystem on a sd card of 1,6GB . Also i have a swap partition of 200MB.
    If i try to copy a file with less of 40MB dimension i don't have any problems.
    If i use 4000 bs instead 40000 i have the same problem.
    In first time i had a kernel linux 3.1.4 and this problem presented with 20MB instead 40MB.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,978
    Myself, I usually run dd with a bs=1M and leave the count to the default. It is a good tradeoff of size vs. speed, and won't have your problem of overrunning the kernel buffers. You could rebuild the kernel with bigger internal I/O buffer sizes, but I wouldn't recommend it, especially for solid-state storage. I assume you meant that the SD card has 16GB, not 1,6?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    How can I increase the size of the I/O buffer in kernel configuration?
    Really i have a compact flash of 2GB total size.
    Could it be a problem for virtual memory?

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,978
    Yes, your problem could be due to bad sectors on the CF card and if the OS can't write VM data to the swap space then that could be the root cause of your kernel panic. Remember that flash memory does have a limited number of write cycles (about 10,000 for NAND flash, which your CF card probably uses), and since VM can be written to quite frequently, this may be what is happening.

    In any case, for embedded systems like this, I always recommend disabling VM swap altogether, and don't allow more runtime applications+data than the physical memory supports. This is where limiting the block size and count of dd is probably your best option.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •