It seems that I misplaced this thread! It isn't the kernel that's at fault after all; it's bash. Perhaps the mods should move it to misc.

I found this out by sheer serendipity, not by using logic. I'm currently building a new LFS and I noticed that the temporary bash in $LFS/tools/bin shows this behaviour and the final version in $LFS/bin does not. The difference is that the final version is built against a separately installed readline while the temporary version uses its own internal version instead. And so, it turns out, does Slackware! Slack has a libreadline.so but bash isn't linked against it.

GNU readline, by default, switches this tiresome behaviour (which is called horizontal-scroll-mode) off. You can also switch it on and off by using a setting in your inputrc file. But bash's internal readline doesn't seem to honour this setting.