Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
When I first started using Linux, you could run over the end of a line in a virtual terminal and it just carried on printing on the next line. You ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190

    Annoying behaviour in a Linux virtual terminal


    When I first started using Linux, you could run over the end of a line in a virtual terminal and it just carried on printing on the next line. You could see the whole of your line at a glance.

    Nowadays, when you reach the side of the screen, the text jumps to the left and the beginning of the line disappears. You can only get it back by moving left with the arrow key, and then of course you can no longer see the end of the line. I think these are framebuffer consoles - they seem to be compulsory when you have a modern video chip with mode-switching selected.

    Does anyone know what kernel flags I could use to get back the old behaviour?
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,032
    It depends on card and processor etc. It is covered here: https://www.linux.com/learn/docs/ldp...mebuffer-howto

    At the end of "5.2 How do I activate the vesafb drivers?" there is this quote:

    NOTE! vesafb does not enable scrollback buffering as a default. You will need to pass to the kernel the option to enable it. Use video=vesa:ypan or video=vesa:ywrap to activate it. Both does the same thing, but in different ways. ywrap is a lot faster than ypan but may not work on slightly broken VESA 2.0 graphic cards. ypan is slower than ywrap but a lot more compatible. This option is only present in kernel 2.1.116 and above. Earlier kernels did not have the ability to allow scrollback buffering in vesafb.

  3. #3
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    626
    Use "xterm" and not "konsole" or "gterminal". You migh also like to have "xtermcontrol" to update xterm settings after it has started.

    I still work using xterm.

  4. #4
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    Quote Originally Posted by gregm View Post
    It depends on card and processor etc. It is covered here: https://www.linux.com/learn/docs/ldp...mebuffer-howto
    That's a very old HOWTO. I wonder how much of it is still relevant
    NOTE! vesafb does not enable scrollback buffering as a default. You will need to pass to the kernel the option to enable it. Use video=vesa:ypan or video=vesa:ywrap to activate it. Both does the same thing, but in different ways. ywrap is a lot faster than ypan but may not work on slightly broken VESA 2.0 graphic cards. ypan is slower than ywrap but a lot more compatible. This option is only present in kernel 2.1.116 and above. Earlier kernels did not have the ability to allow scrollback buffering in vesafb.
    From my reading, scrollback buffering refers to the amount of back-scrolling you can do with Shift-PageUp. Without buffering, previous pages are saved only in video ram; with buffering, you can set aside core ram - as much as you want - for this function. But that's a bit different from this left-right shifting. Anyway I tried booting with vesa:ywrap and vesa:ypan and they had no effect at all.

    Funnily enough, I do have normal console behaviour in Debian which uses an older kernel than Slack. I tried doing a diff on the two kernel config files but obviously there was a huge number of differences because of the different versions, and because Debian uses a stock kernel whereas I built the Slackbody one myself. I couldn't see anything that looked relevant.
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  5. #5
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,032
    I only checked one of my machines but XUbuntu - 3.11.0-18-generic kernel - the console wraps the line. It may be a driver thing more then a kernel thing?

  6. #6
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,032
    I checked Kali with a 3.12 kernel and i wraps as well.

  7. #7
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    Debian Linux-3.2.0 (stock kernel) Long lines in console wrap normally.
    Crux Linux-3.6.11 (hand-rolled). Lines wrap normally.
    Slackbody Linux-3.10.17 (hand-rolled). Lines jump to the left.

    Trust Slackware to be eccentric! Or is this the face of the modern kernel? But then gregm had proper wrapping with a 3.12 kernel.
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  8. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I think that it is a framebuffer issue, causing the framebuffer to be a larger resolution than your actual resolution. It could be corrected by specifying your monitor size on the kernel line, but I have had a video card that didn't matter, even setting it like that didn't work. It had to do with the dpi and the font being used.

    I usually get around it by using a custom framebuffer setup using uvesafb with v86d. I am pretty sure most distros don't have that kernel patch though, but you could apply it.

    Linux User #376741
    Code is Poetry

  9. #9
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    I checked with my other two distros. The Debian Wheezy stock kernel has uvesafb built as a module but it isn't loaded when the console is used. The driver in use seems to be i915. My Crux kernel doesn't have uvesafb at all and i915 is built in. Yet both have normal consoles.
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  10. #10
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I have a laptop like that, it depends on what distro and what video driver I am using. It exhibits the same console behavior you are referring to. It only does it when I disable kms though.

    Linux User #376741
    Code is Poetry

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •