Find the answer to your Linux question:
Results 1 to 3 of 3
For the last week or so, I've been trying to compile the 2.6.10 version of the kernel on my Asus S5 laptop. So far I've got a farely good working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Location
    Portugal
    Posts
    93

    Compiling 2.6.10


    For the last week or so, I've been trying to compile the 2.6.10 version of the kernel on my Asus S5 laptop.
    So far I've got a farely good working kernel

    However, when I boot, I get a Warning saying that HardDrive DMA ir off and that it will slow down fsck. My question:
    Should I turn DMA on, in the BIOS? Will that fix this warning?

    Thnx

    (more doubts to follow)

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    There's an option somewhere in the kernel config called "Use DMA by default on disks" or something of the sort, you might want to enable that.

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    I had this problem, simple to fix.
    1. Make sure it's turned on in the BIOS of course
    2. Make sure it's enabled by default (like the above post said)
    3. Make sure you compiled support for your chipset in directly, NOT as a module.
    Emotions are the key to the soul.
    Registered Linux User #375050

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •