Find the answer to your Linux question:
Results 1 to 9 of 9
Here's the rundown. I recently installed kernel 2.6.8.1 over the RedHat Linux 7.3 default kernel (2.4.1 . I installed the latest version of modutils. I then downloaded rusty's module-init-tools, even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    10

    Some Modules Won't Load. Upgraded From 2.4 To 2.6


    Here's the rundown. I recently installed kernel 2.6.8.1 over the RedHat Linux 7.3 default kernel (2.4.1. I installed the latest version of modutils. I then downloaded rusty's module-init-tools, even ran a "make moveold" for 2.4 compatibility. Everything installed great. My 2.6 kernel modules (serial drivers, ethernet drivers, etc) insert into the kernel with no trouble at all. But, I'm trying to install Conexant modem drivers (provided by Linuxant). Linuxant's script checks some things, downloads the proper package, builds it, and then ATTEMPTS to install it. Toward the end of the installation, it fails saying:

    ERROR: hcfpci driver not active
    error: execution of %post scriptlet from hcfpcimodem-1.03full-1 failed, exit status 1

    ERROR: Installation of the package failed!

    The output of hcfpciconfig --dumpdiag reads this:

    ...
    + modprobe -v /dev/ttySHCF
    install /sbin/modprobe hcfpcihw
    insmod /lib/modules/2.6.8.1/extra/hcfpciosspec.ko diagmajor=242
    WARNING: Error inserting hcfpciosspec (/lib/modules/2.6.8.1/extra/hcfpciosspec.ko): Invalid module format
    insmod /lib/modules/2.6.8.1/extra/hcfpciengine.ko
    WARNING: Error inserting hcfpciengine (/lib/modules/2.6.8.1/extra/hcfpciengine.ko): Invalid module format
    insmod /lib/modules/2.6.8.1/extra/hcfpciserial.ko serialmajor=240
    WARNING: Error inserting hcfpciserial (/lib/modules/2.6.8.1/extra/hcfpciserial.ko): Invalid module format
    insmod /lib/modules/2.6.8.1/extra/hcfpcihw.ko
    FATAL: Error inserting hcfpcihw (/lib/modules/2.6.8.1/extra/hcfpcihw.ko): Invalid module format
    FATAL: Error running install command for /dev/ttySHCF
    ...

    On my 2.4, the installation finished and the modem worked perfectly. But as you can see, I am having problems. I check the file extension for the modules, it is the ".ko" file extension which is, as I understand, a 2.6 kernel extension for modules. I have looked for answers many places. Unfortunately, there's not a whole lot of Linuxant driver gurus out there.

    This sucks though. Any suggestions would be helpful for sure. Thanks.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    You might want to think about upgrading the whole system... 7.3 is very old by now.
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    10
    I realize I could just upgrade, but I would definitely like to know why this problem is occuring. I want to understand it. But yeah, you're right I should probably get something newer. Anything else fellas?

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    yeah all you need to do is put the modules into the kernel-2.6 folder to have then load on boot... in gentoo that is /etc/modules.autoload.d/kernel-2.6 in your distro it may be in a slightly diffrent location
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  5. #5
    Linux Newbie
    Join Date
    Feb 2005
    Location
    Lebanon, PA
    Posts
    110
    So, I'm Slackware 10.1 and went from kernal 2.4.29 to 2.6.11. My network card and sound card did not insert into the kernal. You're saying I can copy modules from the 2.4.29 stuff into the 2.6.11 src folder and compile again? (This was my first compile.)
    'Linux is like a swiss army knife. Yet it never gets that "I'm bloated and need suspenders" feeling.' - www.arkaoss.com

  6. #6
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    I think a
    Code:
    make modules
    make modules_install
    should do for you. If you have configured your network card and sound card as modules

  7. #7
    Linux Newbie
    Join Date
    Feb 2005
    Location
    Lebanon, PA
    Posts
    110
    I hadn't configured them as modules, I configured them to build in the kernal. But here's the things:

    Network: I didn't see my network card listed, so I'm assuming that's why I didn't get network. With my 2.4.29 kernal, network was in there. (3c5xx)

    Sound: During boot up I get messages about my sound from Alsa. I figure I should try to get the messages and put them here, so I will do that as soon as I can.
    'Linux is like a swiss army knife. Yet it never gets that "I'm bloated and need suspenders" feeling.' - www.arkaoss.com

  8. #8
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Here's a little help doc I wrote up for a friend when he wanted to upgrade to 2.6 from the 2.4 series...I was running Slack (as one of many distros on that box) at the time and decided to write up a few helpful hints:

    Copy your .config file from your 2.4 kernel (usually in /usr/src/linux) to the new kernel source directory, run "make xconfig" (or gconfig,menuconfig, etc.), select any new options, and then compile using "make bzImage && make modules && make modules_install". Go to the fridge or something while it compiles...it will take a while.

    After that's done, you copy your System.map file from the new kernel source and the bzImage file (in arch/i386/boot) to your /boot directory. Copy the text from within /etc/modules.conf to /etc/modprobe.conf. Edit /etc/lilo.conf to include a boot entry that points to your new bzImage file, run "lilo", and reboot into the 2.6 kernel.

    If you are going to install nVidia display drivers, copy the new kernel source directory to /usr/src and set up the "linux" symlink in that directory to point to the new kernel source directory, then run the installer as you normally would.

    Oh, almost forgot...if you have a cd burner, you should remove the append entry "hdc=ide-scsi" from your /etc/lilo.conf file if you successfully install the 2.6 kernel. It doesn't need that entry for cd burning.
    If you haven't already, then give swaret a shot for packages (setting it up to use packages from "current" keeps your system up to date and about as bleeding-edge as you can); I know that's not kernel-related, but it's a good utility.
    Never had that particular doc fail a Slack user...getting Alsa to behave afterwards can be a bit tricky sometimes, though. Maybe it will help.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #9
    Linux Newbie
    Join Date
    Feb 2005
    Location
    Lebanon, PA
    Posts
    110
    K, did that, went through the makes. On make modules_install I got a bunch of warnings like this...

    WARNING: /lib/modules/2.6.11/kernal/fs/quota_v2.ko needs unknown symbol unregister_quota_format


    Is that a big deal?
    'Linux is like a swiss army knife. Yet it never gets that "I'm bloated and need suspenders" feeling.' - www.arkaoss.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •