Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Initrd stands for initial ramdisk. It's mainly designed to allow system startup to occur in two phases, where the kernel comes up with a minimum set of compiled-in drivers, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204

    Initrd stands for initial ramdisk. It's mainly designed to allow system startup to occur in two phases, where the kernel comes up with a minimum set of compiled-in drivers, and where additional modules are loaded from initrd.

    If you could post the contents of your /boot directory and the contents of your /boot/grub/menu.lst file (or /etc/lilo.conf if you use lilo) we'll be able to see whether you are "calling" your initrd.img file at boot.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  2. #12
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    Hi thanx for ur quick response

    BOOT directory contents are:
    boot.b initrd-2.6.11.img module-info System.map-2.6.11
    chain.b kernel.h module-info-2.4.20-8 vmlinux-2.4.20-8
    config-2.4.20-8 lost+found os2_d.b vmlinuz
    grub message System.map vmlinuz-2.4.20-8
    initrd-2.4.20-8.img message.ja System.map-2.4.20-8 vmlinuz-2.6.11

    menu.lst contents are::
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,5)
    # kernel /vmlinuz-version ro root=/dev/hda7
    # initrd /initrd-version.img
    #boot=/dev/hda
    default=2
    timeout=10
    splashimage=(hd0,5)/grub/splash.xpm.gz
    title Red Hat Linux (2.6.11)
    root (hd0,5)
    kernel /vmlinuz-2.6.11 ro root=LABEL=/
    initrd /initrd-2.6.11.img
    title Red Hat Linux 9.0 (2.4.20-
    root (hd0,5)
    kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
    initrd /initrd-2.4.20-8.img
    title anumolu XP
    rootnoverify (hd0,0)
    chainloader +1
    these are the details given
    ok bye

  3. #13
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    That looks kosher...how did you compile the kernel? Did you use make oldconfig or one of the menuconfig options? If you left out support for the filesystem that your /boot partition is on, you could see this error. There is a very nice howto here: http://www.linuxgazette.com/node/9060
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    i didn't load old config , when i had given "make bzimage" command it displayed a userinterface window there i selected some more options and compiled.
    Ok any way thanx for ur help and for providing good tutorial for kernel compiling!
    ONEMORE what shall i do now ??
    is it possible to remove and compile tht 2.6.11 ?? give me some suggestions wht to do whether to remove or upgrade tht 2.6.11, if upgrade is the option then how to do tht??
    ok bye
    thanx for spending the valuable time 4 me..

  6. #15
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    I also get this error. I tried the two commands that you posted and rebooted, but still got the same error. I think I configured my kernel to have support for my fs (ReiserFS)...I did select it to use it atleasat (maybe I didn't select all of the options that are needed to support the fs?)

    Can I go back and just configure this kernel again and start from there or do I have to start all over? I took a lot of time changing those settings and really don't want to go through all of that again.

    EDIT: I fixed that problem, but now I have another one. The question's in another thread. I fixed it by adding RAMdisk support in the kernel....I didn't have it before. Thanks!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •