Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    unable to mount root fs...;(


    I was looking now for a few hours to solve this problem, but I never found a hint that really could help.. hope here is somebody who knows what to do...
    I have installed Fedora Core 3 and wanted to build my own kernel. Configuring and building was not really a problem, I did it very slowly and added every driver or module I needed directly into it, so i need no initrd. The hard drives get detected correctly, also the partitions are listed correctly, but then occures the following message:
    VFS: Cannot open root device "VolGroup00/LogVol00" or unknown-block(0,0)
    Please append a correct "root=" boot-option
    Kernel panic - not sysncing: VFS: Unable to mount root fs on unknown-block(0,0)

    ext2 and ext3 and also reiserfs are supported by the kernel. (I left all options depending the filesystems the same as in the working standard-redhat kernel, but replaced "module" by "yes"..) I start it with the same parameters the standard-kernel from redhat has. When I replace the "VolGroup00/LogVol00" with the partition it should boot from (hdb2), the problem is the same (Cannot open root device "/dev/hdb2").

    Can anyone help??;(


  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    are you getting the errors within grub or lilo at boot, or does it boot and you get the errors with everything is coming up?
    Operating System: GNU Emacs

  3. #3
    Thanks for your quick response! I get these errors using GRUB. But now it already looks a bit different when I use /dev/hdb1 instead of hdb2.. sorry, I'm absolutely new to this..;(

    My Grub config is:
    title Fedora Core (2.6.10-1.770.FC3)
    kernel /vmlinuz-2.6.10-1.770 ro root=/VolGroup00/LogVol00
    initrd /initrd-2.6.10-1.770.img #This kernel works fine!!
    title Kernel 2.6.10
    kernel vmlinuz-2.6.10 ro root=/dev/hdb1

    The new error message is:
    VFS: Mounted root (ext3 filesystem) readonly
    Freeing unused kernel memory: 252k freed
    Warning: unable to open initial console
    Kernel panic - not syncing: No init found. Try passing init= option to kernel

    and mount says:
    /dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
    none on /proc type proc (rw)
    none on /sys type sysfs (rw)
    none on /dev/pts type devpts (rw,gid=5,mode=620)
    /dev/hdb1 on /boot type ext3 (rw)
    none on /dev/shm type tmpfs (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

    Hope this helps a little bit...

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts