Find the answer to your Linux question:
Results 1 to 5 of 5
I downloaded the latest version of Mandrake and installed it on a system I threw together recently (called pionex). It gave me a Kernel Panic when I tried booting into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    3

    Kernel Panic


    I downloaded the latest version of Mandrake and installed it on a system I threw together recently (called pionex). It gave me a Kernel Panic when I tried booting into the OS, so I tried a slightly older version (10.0) that I had installed on my laptop and works fine. I figured it would work on pionex since it worked on my laptop. It gives me the same error on boot-up (I'll type out the error in a second). I think that 'cause of how the problem seems to be comming even with a version I know works elsewhere, the problem must be with my hardware, but I'm not sure about that.

    The error:

    Creating root device
    Mounting root filesystem
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    pivotroot: pivot_root(/sysroot ,/sysroot/initrd) failed: 2
    umount /initrd/sys failed: 2
    umount /initrd/proc failed: 2
    Initrd finished
    Freeing unused kernel memory: 200k freed
    Kernel panic: No init found. Try passing init= option to kernel.

    Now, I tried the rescue mode to pass an init to the kernel, but then I realized that I didn't know any options (doh!). What should I do?

  2. #2
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    Code:
    Kernel panic: No init found. Try passing init= option to kernel.
    Edit your bootloaders config files to say something like:
    Code:
    kernel /boot/kernel-current root=/dev/hdc1[b]init=3[/b]
    g/l :P
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    3
    Quote Originally Posted by gwalters
    Edit your bootloaders config files to say something like:
    Code:
    kernel /boot/kernel-current root=/dev/hdc1[b]init=3[/b]
    g/l :P
    Where is the bootloader config file? Also, I think I've made myself a problem unless I am thankfully mistaken. When I boot from the Mandrake CD and press F1 for more options and go into the F2-Advanced Help section it says I can choose from two different Kernels:
    Code:
     You can Choose the following kernels  :
                o   alt0 is kernel 2.6.3-7mdkBOOT
                o   alt1 is kernel 2.4.25-2mdkBOOT
    I think that when I installed the older version of Mandrake I may have installed it in conjunction with the newer version on a different harddrive (I have three in this system). I'll have to look into that.

  4. #4
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    assuming you have grub your config file is /boot/grub/grub.conf your last comment about the kernels was rather confusing.
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    3
    Yeah, sorry about the Kernel comment. I figured out what was going on though. Turns out that one of the hard drives was malfunctioning and caused bootloader to think it had the root partition. To be clear, , I had first installed Mandrake with a different master/ slave set up with the hard drives, but it was causing me problems. I had to change it but the original master kept, of course, the older bootloader, and after I changed the master/ slave set up, I forgot to change the BIOS setting. Very simple, costly mistake. Anyway, thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •