Find the answer to your Linux question:
Results 1 to 10 of 10
I have installed an evalution version of SUSE Enterprise Server 9 on a Virtual Machine. I copied the files vmlinuz and initrd to .old versions and then ran the command ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6

    SUSE Enterprise Server 9


    I have installed an evalution version of SUSE Enterprise Server 9 on a Virtual Machine. I copied the files vmlinuz and initrd to .old versions and then ran the command rpm -Uvh kernel-bigsmp-2.6.5-7.111.5.i586.rpm having put the .rpm file in the /boot/ directory.
    This command appeared to have worked, so I restarted the Virtual Machine. On restart it just gave a blank screen. I reset the VM and this time selected the Failsafe boot option. The screen now states;

    Uncompressing Linux... Ok, booting the kernel.

    There is a flashing cursor but nothing else appears to be happening. In case the last paragraph hasn't made this abundantly clear - I'm very new to Linux - so I may have made an elementary mistake . Can anyone shed any light on what I may have done wrong? Is there any way to return to the old kernel when I am unable to boot the virtual machine? I have left it attempting to boot up for 1/2 hour in case it was just slow to boot the first time.

    Any help would be gratefully received.

    Hammers

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    It looks like you didn't add the new kernel to your menu.lst file, and since you renamed your old kernel (which was the default) your bootloader doesn't know where to go.

    I'm not sure about Enterprise 9, but in Suse you can boot from the install disk, select Installation, and then a moment or two later select to Boot an Installed System. Once you've booted, you can rename your vmlinuz, etc. to the proper names and boot normally again...then we can mess with getting you to boot from the new kernel you wanted.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    Wow, thanks. I've managed to get back in to it and I can see the new kernel files in the /boot/ directory.

    What do I need to do to set it to use the new files?

    Thanks for your help.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Create a new section that looks like your default section, but point it at the new kernel and initrd.img instead of the default vmlinuz and initrd.img (usually /boot/kernel-<version_number> and initrd-<version_number).
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    I created a new section on menu.lst based on the default one, and changed the kernel and initrd names to be the new versions.

    When I restarted I had a second Linux option in the menu, which I presume relates to the extra section. However it still will not boot. Any ideas?

    Should I also copy the .old files back to there original name? Presumably that would allow me to boot from the old kernel?

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    I have changed the first section of menu.lst such that it points at the old kernel files (initrd-2.6.5-7.97-default and vmlinuz-2.6.5-7.97-default) and I can now boot from the old kernel.

    But the menu option which points to the new kernel files (initrd-2.6.5-7.111.5-bigsmp and vmlinuz-2.6.5-7.111.5-bigsmp) still will not boot. Is there any thing else I need to do?

  8. #7
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    copy the .old files to their original names; that should let you boot. Then post your menu.lst file, and we'll see what we can do for you (although it may wait until tomorrow for me - sorry, but I have to start drinking...I went to UNC and they're playing for the title tonight )
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    I didn't need to rename the .old files. When I tried to apply the new kernel it changed the initrd and vmlinuz files to names which included their versions. I then changed the menu.lst to point to these versions.

    Below is the menu.lst, and the only problem I have now is that the 'Linux - new kernel' settings do not allow the machine to boot. Any ideas what could be wrong?

    Did UNC win?

    Code:
    # Modified by YaST2. Last modification on Fri Feb 18 15&#58;00&#58;47 2005
    
    
    color white/blue black/light-gray
    default 0
    timeout 8
    gfxmenu &#40;hd0,1&#41;/boot/message
    
    ###Don't change this comment - YaST2 identifier&#58; Original name&#58; linux###
    title Linux
        kernel &#40;hd0,1&#41;/boot/vmlinuz-2.6.5-7.97-default root=/dev/hda2 vga=0x314 selinux=0 splash=silent resume=/dev/hda1 elevator=cfq showopts
        initrd &#40;hd0,1&#41;/boot/initrd-2.6.5-7.97-default
    
    ###Don't change this comment - YaST2 identifier&#58; Original name&#58; floppy###
    title Floppy
        root &#40;fd0&#41;
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier&#58; Original name&#58; failsafe###
    title Failsafe
        kernel &#40;hd0,1&#41;/boot/vmlinuz root=/dev/hda2 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0  3
        initrd &#40;hd0,1&#41;/boot/initrd
    
    ### Paul H copy of default - YaST2 identifier&#58; Original name&#58; linux###
    title Linux-new kernel
        kernel &#40;hd0,1&#41;/boot/vmlinuz-2.6.5-7.111.5-bigsmp root=/dev/hda2 vga=0x314 selinux=0 splash=silent resume=/dev/hda1 elevator=cfq showopts
        initrd &#40;hd0,1&#41;/boot/initrd-2.6.5-7.111.5-bigsmp

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    Can anyone point me in the right direction with this? When I try to boot the new kernel I just get a blank screen. Note - this is in a Virtual Machine using MS Virtual PC, could this be a compatability issue?

  11. #10
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Did UNC win? Very Happy
    Yes, they did...Franklin St. got a bit nutty afterward, too

    You could try adding noapic or acpi=off to your boot options for that kernel...bit of a long shot, but it's surprising how many things that can fix. Your menu.lst file looks kosher, so I guess it just must be a weird compatibility thing with VirtualPC.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •