Find the answer to your Linux question:
Results 1 to 6 of 6
Hi All, I am running FC3 with a 2.6.10 kernel without any problems. I am trying to install a 2.4.21 kernel for an application I am working on. Initially I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    Kernel Panic with Ext2/Ext3 partition check


    Hi All,

    I am running FC3 with a 2.6.10 kernel without any problems.

    I am trying to install a 2.4.21 kernel for an application I am working on. Initially I had problems compiling the 2.4 and after a lot of effort, I changed the gcc to the right version (2.96.3) and was able to compile the 2.4.21 kernel. I also had a problem with 'make install_modules' that version reqired old depmod and I had to create a symlink "ln -s /sbin/depmod /sbin/depmod.old". And finally it compiled and installed.

    But when I try to boot this new 2.4.21, I get a kernel panic message saying:-


    Code:
    Freeing initrd memory: 37k freed
    VFS: Mounted root(ext2 filesystem)
    attempt to access beyond end of device
    01:00: rw=0,want=4612,limit=4096
    attempt to access beyond end of device
    01:00: rw=0,want=4612,limit=4096
    attempt to access beyond end of device
    01:00: rw=0,want=4612,limit=4096
    VFS: Cannot open root device "LABLE=/dev/hda1" or 00
    Please append a correct "root=" boot option
    Kernel panic: VFS: Unable to mount root fs on 00:00

    I googled around and made changes to my grub.conf, without use. Here is the relavent part of my grub.conf:-

    Code:
    #boot=/dev/hda
    default=0
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core (2.4.21)
            root (hd0,0)
            kernel /vmlinuz-2.4.21 ro root=LABEL=/dev/hda1
            initrd /initrd-2.4.21.img

    Here is my relavent part of fstab :-

    Code:
    This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/               /                      ext3    defaults        1 1
    LABEL=/boot      /boot               ext3    defaults        1 2
    none                    /dev/pts           devpts  gid=5,mode=620  0 0
    none                    /dev/shm        tmpfs   defaults        0 0
    none                    /proc                proc    defaults        0 0
    none                    /sys                  sysfs   defaults        0 0
    LABEL=SWAP-hda3  swap     swap   defaults        0 0
    Although, I have enabled ext3 support for the 2.4.21, the initial messages it throws up before kernel panic, tells it is seeing the hard disk as a ext2. I assume ext3 is ext2 with journaling support. So is this behaviour ok? Is this related to the above kernel panic message? Is the new 2.4.21 kernel simply not able to read my partitions that are in ext3? If so, why? Please help.

    I cross checked the .config of 2.6 and the 2.4 for the IDE part and made sure both were the same. Here is the filesystem part of the .config of 2.4, in case it helps you in identifying the problem:-


    Code:
    # File systems
    #
    CONFIG_QUOTA=y
    CONFIG_AUTOFS_FS=y
    CONFIG_AUTOFS4_FS=y
    CONFIG_EXT3_FS=y
    CONFIG_JBD=y
    CONFIG_JBD_DEBUG=y
    CONFIG_FAT_FS=y
    # CONFIG_MSDOS_FS is not set
    CONFIG_VFAT_FS=y
    # CONFIG_JFFS_FS is not set
    # CONFIG_JFFS2_FS is not set
    CONFIG_RAMFS=y
    CONFIG_ISO9660_FS=y
    CONFIG_VXFS_FS=y
    CONFIG_NTFS_FS=y
    # CONFIG_HPFS_FS is not set
    CONFIG_PROC_FS=y
    CONFIG_DEVPTS_FS=y
    CONFIG_EXT2_FS=y
    Although google gave many links to previous kernel panic messages, they were either due to differnt issues or they did not work for me. Your help will be greatly appreciated.

    Thank you,
    K

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    Hi again all,

    I made a small changes in grub.conf
    root=/dev/hda1
    and it worked.

    Now its failing on:-

    Code:
    Waring: unable to open an initial console.
    Kernel panic: No init found. Try parring init= option to kernel

    I guess I have to set some option in the .config. Please help.

    Thank you,
    K

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    An update..I ran a

    /sbin/mkinitrd -v -f /boot/initrd/2.4.21.img 2.4.21

    And now I am getting this message:

    Code:
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted files system with ordered data mode.
    pivotroot: pivot_root(/Sysroot,/Sysroot/initrd) failed: 2
    umount /initrd/proc failed: 2
    freeing unused kernel memory: 276k freed
    Kernel panic: No init found. Try passing init= option to kernel.
    Any pointers, folks?

    Thanks,
    K

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Location
    Texas
    Posts
    1
    kewlemer, I'm the last person anyone would accuse of being a linux guru, but as I have the same error too, I'll play around with my box and let you know if I can get anything working.

    The first idea that comes to mind as to why this is going on is I've installed my distro on a big (250GB) hard drive on an old system that can't understand anything bigger than 137GB (?) and whatever Debian did to fix it, I didn't put in when I compiled my 2.6.12.

    Edit: Oh this retarded. This is one of THE MOST common errors from the looks of a google search, but NO ONE knows how to fix it. I think I might have seen something about cramfs...

  5. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    kewlemer, nothing personal, but it seems you may be trying to get ahead of yourself. Understanding Grub and a couple of other small points is necessary not to waste your efforts in compiling, etc. Enough editorializing....

    I guess RedHat thinks using a "LABEL" on each partition is a good idea, but it is confusing for many people. It is not necessary to have a label on any partition and if you do have a label, it does not need to be refered to. But if you refer to a label, it must be coordinated.

    In your first code entry:
    Code:
    01:00: rw=0,want=4612,limit=4096
    VFS: Cannot open root device "LABLE=/dev/hda1" or 00
    Please append a correct "root=" boot option
    you see that "LABEL" is misspelled, so Linux did not understand. Easy to fix. Next, it appears that you have a separate /boot partition (from your /etc/fstab). Your grub says your kernel is on (hd0,0) but it says the root partition is /dev/hda1, which is the same place.

    Cut to the chase: So I think you have a partition table like this:
    /dev/hda1 /boot
    /dev/hda2 /
    /dev/hda3 swap
    If that is correct, I think you will be able to boot if you make these changes:
    Code:
    #boot=/dev/hda
    default=0
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core (2.4.21)
            root (hd0,0)
            kernel /vmlinuz-2.4.21 ro root=/dev/hda2   <--Get rid of the "LABEL" reference
            initrd /initrd-2.4.21.img
    
    &#40;on to /etc/fstab&#58;&#41;
    
    /dev/hda2      /         ext3    defaults        1 1
    /dev/hda1      /boot     ext3    defaults        1 2
    none           /dev/pts  devpts  gid=5,mode=620  0 0
    none           /dev/shm  tmpfs   defaults        0 0
    none           /proc     proc    defaults        0 0
    none           /sys      sysfs   defaults        0 0
    /dev/hda3      swap      swap    defaults        0 0
    While the /etc/fstab may be perfect without changes, I think that it is less confusing if you don't bother with "LABEL". That way, there is no question as to where anything is. The main problem you have, I think is in the erroneous use of "LABEL on the grub "kernel" line and in the incorrect reference to the root partition. Lemme know how it works out.
    /IMHO
    //got nothin'
    ///this use to look better

  6. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by Netherwolf
    Edit: Oh this retarded. This is one of THE MOST common errors from the looks of a google search, but NO ONE knows how to fix it.
    I think that it's partly due to that a kernel panic can occur due to any number of really trivial things like a simple typo, or it could be something deep in the kernel. Whatever. In any case, it helps to understand what usually (for new users, anyways) causes it, and that's as in kewlemer's case that while the kernel loaded okay, with the incorrect reference to the root partition, the kernel couldn't find the next thing it needs which is /sbin/init. Once init is run, the kernel will have more resources to offer more itelligible messages than just "kernel panic".

    As to your 137Gb drive, when you boot to the Grub splashscreen, look for instructions on how to get the Grub command line. If Grub understands your drive geometry, you will be able to recognize the partitions, directories and filenames through the drive by using the Grub filename completion utility. At the command line, do:
    Code:
    grub> root &#40;hd  <tab>
    &#91;grub will show you what drives it sees.  Let's choose '0'&#58;&#93;
    grub> root &#40;hd0,  <tab>
    &#91;grub will show you what partitions it sees.  Let's choose '2'&#58;&#93;
    grub> root &#40;hd0,2&#41;
    grub> kernel /   <tab>
    &#91;grub will list the files in partition &#40;hd0,2&#41;&#93;
    Of course, if you can't see the filenames listed, either you and Grub don't agree on which drive is which, or Grub doesn't understand your hard drive.

    Cheers~

    edit: (Crap! I just noticed that kewlemer probably solved that over a month ago! See what you made me do, Netherwolf!)
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •