Find the answer to your Linux question:
Results 1 to 3 of 3
Hi friends: I am installing the linux kernel 2.6.11.7 in suse linux 9 the instalation was with make menuconfig make & make modules_install But how begin show a kernel panic ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Kernel Panic


    Hi friends:

    I am installing the linux kernel 2.6.11.7 in suse linux 9
    the instalation was with make menuconfig
    make & make modules_install

    But how begin show a kernel panic with message:

    with initrd-2.6.11;
    RAMDISK: cramfs filesystem found at block 0
    RAMDISKl Loading 1228KiB [1 disk] into ram disk.. done.
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

    VFS: Cannot open root device "hda7"
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

    yo compile raiserfs dentro del kernel

    sorry but i dont no speak english

    Que estará pasando disculpen la ortografia es que no hablo muy bien ingles

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104

    ME TOO

    I am having the same problem with the default Slackware 10.0 KERNEL.
    My New years Resolution is 1280x1024

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Nuremberg/Germany
    Posts
    22
    Hi.

    You installed typing
    Code:
    make menuconfig
    make install
    make modules_install
    and you inserted reiserfs _NOT_ as a module indeed?
    If your root partition is a reiser file system you have to
    insert the driver.

    Other point may be, that you're using S-ATA harddisks and enabled
    the SCSI-option for S-ATA drives during kernel-compilation.

    Then your root-Filesystem is not on /dev/hda# (for example)
    but on /dev/sda# . (where # is the number of your root-partition on the harddisk)

    You may try it out stopping the boot process during the lilo boot prompt
    and type in your kernel-name and append the "root=/dev/sda#" option.

    For example:
    linux root=/dev/sda1

    (you might even try
    linux reiserfs root=/dev/sda1
    if you compiled reiserfs as a module...)


    Good luck,
    Stephan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •