Find the answer to your Linux question:
Results 1 to 4 of 4
I have recently upgraded my kernel to the 2.6.8 AMD K7 package, and i now have no mouse support in X Windows. I get an error message saying that /dev/psaux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    Upgrading to 2.6.8 from 2.4


    I have recently upgraded my kernel to the 2.6.8 AMD K7 package, and i now have no mouse support in X Windows. I get an error message saying that /dev/psaux doesn't exist. I have heard that psaux was replaced by /input/mice but that doesn't exist either. Is it possible that this kernel wasn't compiled with PS/2 mouse support ? If so is there any way to fix it ?

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    I think: recompiling your kernel? In the meantime I'd return to your 2.4 version, if possible.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    Upgrading to 2.6.8 from 2.4

    I am running my 2.4 kernel right now. It's the only way i can run X Windows. I am trying to avoid compiling my own kernel as last time i did it totally trashed my system and i had to re-install. So i am trying to find a debian package that will work. Or some way to change the kernel after it has been compiled.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    I fixed it, sort of

    I managed to get my mouse to work, however, only if i run

    modprobe mousedev
    modprobe psmouse

    after that the mouse works, but how can i get that to load on startup ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •