Find the answer to your Linux question:
Results 1 to 6 of 6
I just compiled kernal version 2.6.11. Everything went fine except for the fact that my eth0 device isn't recognized. I believe my eth0 device is built into my motherboard (laptop) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    6

    Compile Question.


    I just compiled kernal version 2.6.11. Everything went fine except for the fact that my eth0 device isn't recognized. I believe my eth0 device is built into my motherboard (laptop) I'm curently running the latest version of slackware. Could anyone point me in the right direction for getting my eth0 recognized, or is this an issure where I'd have to re-compile? Thanks.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    What kind of device is it?

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    It's a ethernet adapter that's built into my mother board, I called the company who made my laptop, they said it has no name, or identification of any sort. It's simply "built-in".

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    you can find out the model via:
    Code:
    lspci

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Yes I found that command in a book and found all my proper modules and chipsets. I get no errors now when I make bzImage. However I'm now getting an error when I make modules, something about SCSIdpt :I2o. And now when I try to boot my new kernal I'm getting this error:
    Please append correct root=
    Kernal Panic not syncing VFS unable to mount root fs on unknow block (3,1).

    I've tried every VFS option in the kernal config it seems to have nothing to do with that, so I'm assuming it has something to do with the SCSI error. I'm going to try once more tonight leaving all SCSI option on there defualt setting. If any one has any ideas I'd appreciate it. Thanks.

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    I got it. Apparently my problem was that I had my filesystem set as a module instead of just the option for support. I feel stupid, but at least I have my eth0 back. As for my wireless card, that's another day. Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •