Find the answer to your Linux question:
Results 1 to 3 of 3
I have problem updgrading to kernels from 2.6.10 and above. I don't know if I should post this here or under some modem thread, but if I should have done ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Here!
    Posts
    18

    Problem migrating to kernels 2.6.10 and above...


    I have problem updgrading to kernels from 2.6.10 and above. I don't know if I should post this here or under some modem thread, but if I should have done the latter one, please let me know to move it there (or any admins/mods move it there, please).

    I have a Smart Link modem on my laptop, which requires some particular modules from smlink.com. I downloaded them, and it mentioned at the site that they work with 2.4 and 2.6 kernels. I had configured my modules just fine (and I also got online just fine) from knoppix with kernel 2.4.27, but when I decided that I had to upgrade my kernel (2.6.11.7 was out, then) and I also decided that I had to get a decent distro, I got gentoo (and after reading some guides I managed to install it) and kernel 2.6.11.7. I then tried to install the modem modules, and got the following error:

    FATAL: Error inserting slamr (/lib/modules/2.6.11.7/extra/slamr.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    so I checked dmesg and these are the last lines of it:

    slamr: module license 'Smart Link Ltd.' taints kernel.
    slamr: Unknown symbol get_device
    slamr: Unknown symbol put_device
    slamr: Unknown symbol device_release_driver


    So, I found out that my modem modules will NOT work for ANY kernels from 2.6.10 and above, and I will have to cope with kernels from 2.6.9 and below...

    The problem is that, I want to try a new distro (h3knix 2.2, to be exact) which is incompatible with kernels from 2.6.11.2 and below, and thus will only work with kernels above 2.6.11.2....

    Please help me as soon as possible. Thank you for taking some of your time reading this.


    - ardeth

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    7
    The kernel ABI has changed from 2.6.9 onwards, which breaks binary modules such as this.

    The standard 'Free software' response here is that you should be writing to the makers of the modem chipset and asking for a proper Free software driver under the GPL/BSD license.

    Realistically the modem manufacturer either can't or won't do this, so you're stuck with older kernels until they either decide to release a new version that's compiled against the newer kernels, or you're stuck without a usable modem on the laptop.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Location
    Germany
    Posts
    4
    You need:

    slmodem-2.9.10-abby.diff
    ungrab-winmodem.tar.gz

    patch the driversource from smartlink ( I did it with 2.9.10 driver and 2.6.11.4 kernel):

    copy slmodem-2.9.10-abby.diff into the dir where the smartlink driver resides
    cd into the directory where the smartlink driver resides>

    # patch -p1 --dry-run < slmodem-2.9.10-abby.diff
    if everything works fine ( no error messages) then do
    # patch -p1 < slmodem-2.9.10-abby.diff

    then
    # make
    # make install

    Now unpack ungrab-winmodem.tar.gz, cd into the created directory and run
    # make
    # make install

    then do
    # modprobe ungrab-winmodem
    # modprobe slamr
    and eveything should work fine

    Maybe you have to modify init-scripts in a way they load ungrab-winmodem
    BEFORE loading slamr. To get the above mentioned files, just google for them
    .
    read the READMES!
    if nothing works, feel free to email me
    GOOD LUCK
    yifter

    AHH samb: that was good HELP, although you´re right (in a way).
    That´s no flame!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •