Find the answer to your Linux question:
Results 1 to 8 of 8
I've just compiled 2.4.31 kernel for Debian sarge and when booting, it gives me errors like: Loading modules : ide-cd modprobe: Can't locate module ide-cd (I don't have a CD-ROM) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    Estonia
    Posts
    6

    Kernel module errors on boot...


    I've just compiled 2.4.31 kernel for Debian sarge and when booting, it gives me errors like:

    Loading modules : ide-cd modprobe: Can't locate module ide-cd (I don't have a CD-ROM)
    ide-detect modprobe: Can't locate module ide-detect
    ide-disk modprobe: Can't locate module ide-disk
    psmouse modprobe: Can't locate module psmouse (Don't have a mouse nor ps2 port)
    Skipping unavailable hardware/built-in 8139too module.
    Skipping unavailable hardware/built-in piix module.
    Skipping unavailable hardware/built-in usb-uhci module.
    Kernel hotplug support not enabled.

    Firewall: Loading kernel modules: ip_tables, modprobe: Can't locate module ip_tables, ip_conntrack, ip_conntrack version 2.1 (512 buckets, 4096 max) - 288 bytes per conntrack
    ip_conntrack_ftp, iptables_nat, ip_nat_ftp

    but these modules are in the kernel! blink.gif
    here's a list of the configuration.

    and how do I get the full boot log?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Well for one, you might want to build hotplug support into your kernel.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Location
    Estonia
    Posts
    6
    Why would I need this? What does it do?
    I believe I didn't had it with my last kernel either, that worked just fine...

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    It's just a suggestion, probably won't fix your problem, but hotplug helps detect when a device is plugged in, and tries to load the appropriate modules/firmware for it.

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Location
    Estonia
    Posts
    6
    This is just an old computer - for internet gateway, no monitor, no x, no usb devices etc. But thanks.

  6. #6
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    check the file prob somewhere in /etc/ that the list of modules to load on boot and remove all the ones that you didnt build in the new kernel that are in there the file might be /etc/modules
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Location
    Estonia
    Posts
    6
    /etc/modules contains these:
    ide-cd
    ide-detect
    ide-disk
    psmouse

    I'm guessing I just miss the modules somehow. Although I did "make modules_install". /lib/modules/2.4.31 folder is missing some modules... like 8139too Why aren't they there? This didn't happen in 2.4.22

    I believe the problem is with "make modules_install" since many modules are missing? What should I do about this?

  8. #8
    Just Joined!
    Join Date
    Sep 2005
    Location
    France
    Posts
    1
    This reply may be a bit late regarding the original posting date.

    I just had the same kind of problem with a new kernel (2.6.13) I compiled for my debian distro. I have used a .config file that I downloaded expected to offer just the right settings for my laptop and I had to cope messages about missing modules.

    Actually, the missing modules were either absent (useless for my computer) or were built in the kernel. There were two kinds of problems though:

    - some modules were to be loaded at boot because they appeared in the /etc/modules file.
    - discover wanted to load other modules at boot since the corresponding hardware was detected but could not load "modules" because drivers were built-in.

    What I did was :
    - I removed every unnecessary module name in /etc/module
    - I created a new file /etc/discover.d/built-in where I put the following lines, asking not to try to load any modules that is already built-in
    skip usb-uhci
    skip ehci-hcd
    skip i810_rng
    skip piix

    Now I no longer have the previous error messages at boot time !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •