Find the answer to your Linux question:
Results 1 to 3 of 3
I ran into what seems like a serious problem. After going through "make oldconfig" i do/get this: Code: $ make dep *** Warning: make dep is unnecessary now. $ make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45

    going from 2.4.29 to 2.6.13.1 error


    I ran into what seems like a serious problem. After going through "make oldconfig" i do/get this:

    Code:
    $ make dep
    *** Warning: make dep is unnecessary now.
    
    $ make bzImage
    CHK include/linux/version.h
    UPD include/linux/version.h
    SYMLINK include/asm -> include/asm-i386
    SPLIT include/linux/autoconf.h -> include/config/*
    HOSTCC scripts/genksyms/genksyms.o
    SHIPPED scripts/genksyms/lex.c
    SHIPPED scripts/genksyms/parse.h
    SHIPPED scripts/genksyms/keywords.c
    HOSTCC scripts/genksyms/lex.o
    SHIPPED scripts/genksyms/parse.c
    HOSTCC scripts/genksyms/parse.o
    HOSTLD scripts/genksyms/genksyms
    CC scripts/mod/empty.o
    HOSTCC scripts/mod/mk_elfconfig
    MKELF scripts/mod/elfconfig.h
    HOSTCC scripts/mod/file2alias.o
    HOSTCC scripts/mod/modpost.o
    HOSTCC scripts/mod/sumversion.o
    HOSTLD scripts/mod/modpost
    HOSTCC scripts/kallsyms
    HOSTCC scripts/conmakehash
    CC arch/i386/kernel/asm-offsets.s
    CHK include/asm-i386/asm_offsets.h
    UPD include/asm-i386/asm_offsets.h
    CC init/main.o
    CHK include/linux/compile.h
    UPD include/linux/compile.h
    CC init/version.o
    CC init/do_mounts.o
    LD init/mounts.o
    CC init/initramfs.o
    CC init/calibrate.o
    LD init/built-in.o
    HOSTCC usr/gen_init_cpio
    CHK usr/initramfs_list
    /usr/src/linux-2.6.13.1/scripts/gen_initramfs_list.sh: Cannot open 'm'
    make[1]: *** [usr/initramfs_list] Error 1
    make: *** [usr] Error 2
    Then it returns me to the prompt

    Anyone know where i went wrong?

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Location
    India
    Posts
    6

    going from 2.4.29 to 2.6.13.1 error

    why dont you check out if you have modutils-2.4.25-9

    try doing insmod --version or depmod --verision
    it should be anything more than 2.4.2

    and then you should also try

    # make zImage

    i was able to recompile my kernel which was a 2.4.18-14(redhat 8.0) to 2.6.13.1(the latest one)
    without any problems. before you compile your kernel read the ./Documentation/Changes file in the tar.bz2 package.

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1

    The same problem. Solved

    # make menuconfig

    Go to section "General setup"

    you can see "m" in "Initramfs source file(s)", so change it into blank

    exit saving configuration, and make bzImage again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •