Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Hi, I understand you very good about this problem. All over the net everybody posts help manuals about kernel compiling but nobody says the last step - making initrd.img file. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1

    Smile The Answer Of Your Question


    Hi, I understand you very good about this problem. All over the net everybody posts help manuals about kernel compiling but nobody says the last step - making initrd.img file. This file loads your kernel from the partition where is it. The kernel panics because there no connection between them - the initrd.img. Open the /boot directory and you will see that your current kernel have a initrd.img. I had the same problem like you when I compiled my first kernel, because nobody says something about that . Don't worry, this step is very simple. You must use mkinitrd to make the initrd.img file. The question is how to use it. Tell me your distro and I will tell you the exactly command. In SuSE the command is "mkinitrd -k vmlinuz-2.6.15 -i initrd.img-2.6.15" (without the quotes), in Ubuntu is "mkinitrd -o initrd.img-2.6.15 2.6.15" (without the quotes). After that you must add a line to the lilo.conf file in the section for the new kernel "initrd=/boot/initrd-2.6.15.img" (without quotes) and after that to execute in the console the command lilo . Thats it! Now reboot your machine and load the new kernel. Don't forget that the number 2.6.15 isn't right for you. The number is a simple part of the name. If the kernel name is vmlinuz-2.6.15-2 you must use that in the place of vmlinuz-2.6.15, and your initrd.img-2.6.15 will be initrd.img-2.6.15-2. Ask Google for more help about using mkinitrd. Feel free to ask me if you have any questions at neter@mail.bg , because I entered in this forum in accident and may be I will never see this forum again One God Knows. Peace

  2. #12
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2
    I have the same problem yet the suggested solution did not work for me. I just disabled loadable modules in my kernel and I still get the same message!!! What do I try now?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •