Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I can't get kernel 2.6.15 boot properly. Here's what it prints out on screen on startup: kernel-panic:udf-fs: no partition found not syncing: vfs unable to mount root fs on unknown ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    16

    UFD-FS kernel panic 2.6.15


    I can't get kernel 2.6.15 boot properly. Here's what it prints out on screen on startup:

    kernel-panic:udf-fs: no partition found not syncing: vfs unable to mount root fs on unknown block (3,1)

    I've compiled ext2,ext3 and reiserfs as "built-in" as well as IDE support.

    I don't have SATA disks.

    Here's some important files:

    /etc/lilo.conf

    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    boot = /dev/hda
    message = /boot/boot_message.txt
    prompt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # Normal VGA console
    # vga = normal
    # VESA framebuffer console @ 1024x768x64k
    # vga=791
    # VESA framebuffer console @ 1024x768x32k
    # vga=790
    # VESA framebuffer console @ 1024x768x256
    # vga=773
    # VESA framebuffer console @ 800x600x64k
    # vga=788
    # VESA framebuffer console @ 800x600x32k
    # vga=787
    # VESA framebuffer console @ 800x600x256
    # vga=771
    # VESA framebuffer console @ 640x480x64k
    # vga=785
    # VESA framebuffer console @ 640x480x32k
    # vga=784
    # VESA framebuffer console @ 640x480x256
    # vga=769
    # End LILO global section
    # Windows bootable partition config begins
    other = /dev/hdb1
    label = Windows
    table = /dev/hdb
    # Windows bootable partition config ends
    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/hda1
    label = Linux
    read-only
    # Linux bootable partition config ends

    --------
    /etc/fstab
    --------

    /dev/hda2 swap swap defaults 0 0
    /dev/hda1 / reiserfs defaults 1 1
    /dev/hdb1 /windows ntfs ro 1 0
    /dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

    My ide controller:
    00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 12)

    PIIxn-something is the only option related to intel ide controller into config process:
    CONFIG_BLK_DEV_PIIX=y

    I'm out of ideas... I don't know what else I could try

    *Note:

    I built kernel "from scratch" without doing "make oldconfig"

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    2
    That's a wierd problem you're having. The system should be able to mount your root partition since you have built in support of the filesystem. What kind of filesystem does your root partion have? What kind of device filesystem are you using? I had this problem with archlinux but somehow solved it but don't remember how. Make sure everything related to your block devices is compiled in during your kernel compilation process, you may have missed something.

    PS: I recommend switching your boot manager to grub since it allows you to edit your boot paramaters without being booted into the system. It is way more flexible and may help you out in your kernel debugging process.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    1

    Re:

    Hi, I've exactly the same problem like you, also the same version of kernel. I can't find where the problem is, but when I solve it I'll let you know how.
    Have you already find where is the problem? If yes post it please, you'll help me much!
    thx

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4

    found a solution yet?

    Quote Originally Posted by niko77
    Hi, I've exactly the same problem like you, also the same version of kernel. I can't find where the problem is, but when I solve it I'll let you know how.
    Have you already find where is the problem? If yes post it please, you'll help me much!
    thx

    Hi, I also have this problem and am very stuck. Do you have any advice?
    George

  5. #5
    Just Joined! tb10alj's Avatar
    Join Date
    Feb 2006
    Location
    Germany
    Posts
    31
    Did you rerun lilo after installing the new kernel?
    If you forget this, very obscure things can happen.

    This is one more reason for changing to GRUB

    JAN

  6. #6
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Quote Originally Posted by tb10alj
    Did you rerun lilo after installing the new kernel?
    If you forget this, very obscure things can happen.

    This is one more reason for changing to GRUB

    JAN

    hi,
    I actually am using GRUB. but I get the same result when trying to reboot after installing kernel 2.6.15:

    kernel-panic:udf-fs: no partition found not syncing: vfs unable to mount root fs on unknown block (3,3)


    I actually did NOT rerun grub after installing the kernel, and think this may be a source of the problem. Do you agree?--or is it just a lilo thing.

    When I try to repair the system (from SUSE installation gui), I'm told that /hda2 doesn't have a valid swap space--but it IS the swap space. I can try to delete it can create it again, but then I'm told to assign mount point / to a partition--but I don't seem permitted to do this for any of my partitions (gui for setting mount point is not accessible).

    any suggestions on what to do?
    George

  7. #7
    Just Joined! tb10alj's Avatar
    Join Date
    Feb 2006
    Location
    Germany
    Posts
    31
    Quote Originally Posted by tourtelt
    hi,
    I actually am using GRUB. but I get the same result when trying to reboot after installing kernel 2.6.15:

    kernel-panic:udf-fs: no partition found not syncing: vfs unable to mount root fs on unknown block (3,3)
    Hmmm, really strange...
    Could you post your grub.conf/menu.lst and your /etc/fstab?

    And you really compiled in the drivers for your root filesystem
    and your harddisk controller (or have them available in
    an initial ramdisk)?

    I actually did NOT rerun grub after installing the kernel, and think this may be a source of the problem. Do you agree?--or is it just a lilo thing.
    No, you don't have to run GRUB. That's only a lilo thing.

  8. #8
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Could you post your grub.conf/menu.lst and your /etc/fstab?
    here is my /etc/fstab :

    /dev/root / ext2 defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0


    I don't see grub.conf/menu.lst (what directory should it be in?)

    It might be because I'm logged in in Rescue mode. I don't see anything in /boot or /home


    And you really compiled in the drivers for your root filesystem
    and your harddisk controller (or have them available in
    an initial ramdisk)?
    well, after setting up the .config file, from the new kernel dir I did:
    make dep
    make clean
    make bzImage
    make modules
    make modues_install
    make install
    cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.15
    cp System.map /boot
    then rebooted and got kernel panic message

  9. #9
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Could you post your grub.conf/menu.lst and your /etc/fstab?
    here is my /etc/fstab :

    /dev/root / ext2 defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0


    I don't see grub.conf/menu.lst (what directory should it be in?)

    It might be because I'm logged in in Rescue mode. I don't see anything in /boot or /home


    And you really compiled in the drivers for your root filesystem
    and your harddisk controller (or have them available in
    an initial ramdisk)?
    well, after setting up the .config file, from the new kernel dir I did:
    make dep
    make clean
    make bzImage
    make modules
    make modues_install
    make install
    cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.15
    cp System.map /boot

    then rebooted and got kernel panic message

  10. #10
    Just Joined! tb10alj's Avatar
    Join Date
    Feb 2006
    Location
    Germany
    Posts
    31
    Quote Originally Posted by tourtelt
    here is my /etc/fstab :

    /dev/root / ext2 defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    Oh, this is not your original /etc/fstab file
    Looks like the /etc/fstab of your "rescue system"...
    You have to mount your root partition manually.

    I don't see grub.conf/menu.lst (what directory should it be in?)
    It should be in /boot/grub.

    It might be because I'm logged in in Rescue mode. I don't see anything in /boot or /home

    well, after setting up the .config file, from the new kernel dir I did:
    Did you use your old kernel config or did you start your config
    "from scratch"?

    make dep
    make clean
    make bzImage
    make modules
    make modues_install
    make install
    cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.15
    cp System.map /boot
    You don't have to copy your kernel manually to /boot, when you called
    make install. "make install" copies the kernel image, the config file and
    the system.map file to the boot directory.
    For a 2.6 Kernel you don't have to call make dep clean bzImage.
    Since 2.6 "make" is enough. So simply call:
    Code:
    make
    make modules_install
    make install

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •