Find the answer to your Linux question:
Results 1 to 5 of 5
Hi I compiled the kernel with Magic System Request options the kernel work's but it gets stuck sometimes, it happened a couple of times i have no idea why? Anyway ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    17

    Cool Problem with kernel config


    Hi
    I compiled the kernel with Magic System Request options the kernel work's but it gets stuck sometimes, it happened a couple of times i have no idea why?
    Anyway i'm trying to compile it again but can't even get the config running
    I tryed:
    - copy the old confilg to .config
    - make oldconfig
    - make config
    - make xconfig
    but every time i get:
    root@ubuntu:/usr/src/linux3# make oldconfig
    HOSTCC scripts/basic/fixdep
    scripts/basic/fixdep.c:105:23: error: sys/types.h: No such file or directory
    scripts/basic/fixdep.c:106:22: error: sys/stat.h: No such file or directory
    scripts/basic/fixdep.c:107:22: error: sys/mman.h: No such file or directory
    scripts/basic/fixdep.c:108:20: error: unistd.h: No such file or directory
    scripts/basic/fixdep.c:109:19: error: fcntl.h: No such file or directory
    scripts/basic/fixdep.c:110:20: error: string.h: No such file or directory
    scripts/basic/fixdep.c:111:20: error: stdlib.h: No such file or directory
    scripts/basic/fixdep.c:112:19: error: stdio.h: No such file or directory
    In file included from /usr/lib/gcc/i486-linux-gnu/4.0.2/include/syslimits.h:7,
    from /usr/lib/gcc/i486-linux-gnu/4.0.2/include/limits.h:11,
    from scripts/basic/fixdep.c:113:
    ...
    ...
    make[1]: *** [scripts/basic/fixdep] Error 1
    make: *** [scripts_basic] Error 2

    I tryed opening the source code to a new folder but i get the same error
    and make mrproper make clean didn't help either
    Does someone know why the system gets stuck after i compiled it ??
    and why can't I config a new kernel ??
    thanks

  2. #2
    Just Joined! tb10alj's Avatar
    Join Date
    Feb 2006
    Location
    Germany
    Posts
    31
    Hmmmm,

    try to install the libc6-dev package.
    Does this help?


    Cheers,
    JAN

  3. #3
    Just Joined! sourcetrunk's Avatar
    Join Date
    Oct 2006
    Posts
    1
    I don't know if it helped him, but it certainly helped me ...
    (is about 7 years ago since I compiled a linux kernel from source)

    an old BSD addict thanks you.
    Dimi.

  4. #4
    Just Joined!
    Join Date
    Apr 2007
    Posts
    1

    yes, it worked for me too

    Thank you very much

  5. #5
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3

    Thumbs up Worked for me too!!

    Hey tb10alj,
    It worked for me too!!!
    Thanks a lot!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •