Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Originally Posted by dravenloft because I have an rt8139cp card Then use Originally Posted by make menuconfig Device Drivers ---> Network device support ---> Ethernet (10 or 100Mbit) --->[*] EISA, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211

    Quote Originally Posted by dravenloft
    because I have an rt8139cp card
    Then use
    Quote Originally Posted by make menuconfig
    Device Drivers --->
    Network device support --->
    Ethernet (10 or 100Mbit) --->[*] EISA, VLB, PCI and on board controllers
    <M> RealTek RTL-8129/8130/8139 PCI Fast Ethernet Adapter support
    instead.

    And disable the buggy one
    Code:
    RealTek RTL-8139 C+ PCI Fast Ethernet Adapter support (EXPERIMENTAL)
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  2. #12
    Just Joined!
    Join Date
    Jun 2006
    Posts
    50
    Quote Originally Posted by antidrugue
    Then use

    instead.

    And disable the buggy one
    Code:
    RealTek RTL-8139 C+ PCI Fast Ethernet Adapter support (EXPERIMENTAL)
    /Hangs head in shame/ You mean there're two 8139 drivers? Methinks at some point there should be a kernel config tool that organises things in less of a list... I apparently had skipped over this interesting bit of detail.

  3. #13
    Just Joined!
    Join Date
    Jun 2006
    Posts
    50
    Hurray!! Kernel compiled.

    bad thing... it doesn't boot:
    Code:
    VFS: Cannot open root device "hda5" or unknown-block(0,0)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(0,0)
    ok
    1) this happens no matter what device I select. hda, hde, LABEL=/ whatever. It also doesn't matter if rootfs is on (hd0,0) or (hd1,0) to GRUB.

    2) I don't have the slightest idea where to fix this. I don't know if it has to do with a make-kpkg option, or if it's something I did in my .config (or maybe didn't do).

    What I do know is that this is a real bummer.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jun 2006
    Posts
    50
    Ok. This thread is pretty well done for me.

    Turns out that that experimental 8139c driver needs to be off, and the same for an experimental tulip driver. You also have to, for some reason, use make-kpkg --initrd (something I'd already learned the hard way more than once... you'd think I'd remember eventually).

  6. #15
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14
    this worked great for me I finally got the kernel to compile thank you verry much.....
    but now iptables does not start I can't start shorewall anymore
    I was planning to upgrade to etch but I will do that when I have succes in compiling the kernel with iptables capability

    thanks in advance....

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •