Find the answer to your Linux question:
Results 1 to 4 of 4
Alright, I've taken the plunge and compiled the 2.6 Kernel. And recompiled it. Again, and again, and again. The kernel *does* boot, but for whatever reason I can't get into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    19

    Problems with 2.6.2 kernel in text mode/booting


    Alright, I've taken the plunge and compiled the 2.6 Kernel. And recompiled it. Again, and again, and again. The kernel *does* boot, but for whatever reason I can't get into any terminals outside of X. I'm running Mandrake 9.2... and after I select the 2.6.2 kernel in the LILO bootloader, the screen goes blank until X starts and the login screen comes up. Ctrl+Alt+F1 yields a garbled screen, I can't see any text at all.

    I have read the post-halloween document. I have enabled "y" to CONFIG_VT, CONFIG_VT_CONSOLE, CONFIG_VGA_CONSOLE, CONFIG_INPUT, and even made sure that fonts are configured (CONFIG_FONTS=y, CONFIG_FONT_8x8=y, CONFIG_FONT_8x16=y). I've also tried setting vga=normal in /etc/lilo.conf with no avail.

    I've pretty much run out of ideas. I would settle for this, except that 1) it's bugging me that I can't get it to work, and 2) If X ever craps out I'm screwed. Anyone have any suggestions? Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you compile any kind of framebuffer support at all? If so, try disabling it and try again.

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    19

    Still no success

    Device Drivers > Graphics Support > Support for frame buffer devices

    Tried disabling it, enableing it and toggling VGA 16-color/VESA each on and off, also ATI Mach64 as module (I have Mach64 graphics chipset), as well as Framebuffer Console support. None which seem to be working. I still have a few combinations yet to try, though.

  4. #4
    Just Joined!
    Join Date
    Feb 2004
    Posts
    19

    Nearly there

    Well, I have the console working in text mode now, and X still works. I had to enable frame buffer support for my Mach64 chipset, as well as modularly compile in console framebuffer support. Then I changed vga=normal in lilo.conf, and things work again, even though they're in 80x25. At least it functions. I wonder if my previous config of vga=778 was somehow sending a clock signal too high or low for the monitor... I'll have to swap monitors for one that will alert me to such a thing and try it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •