Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I'm running Linux (BusyBox with 2.4.21) on a PC104 board (Prometheus from Diamond Systems Corporation) and I installed apmd 3.0.2-18 on it. The problem is that, while apmsleep ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Location
    College Station USA
    Posts
    1

    apmd - apmsleep does not wake up


    Hello all,

    I'm running Linux (BusyBox with 2.4.21) on a PC104 board (Prometheus from Diamond Systems Corporation) and I installed apmd 3.0.2-18 on it. The problem is that, while apmsleep is able to put the computer to suspend, it does not wake up after the specified time. I have to press any key to wake it up and the command exits gracefully saying "Time Leap Detected" once I pressed a key.
    The BIOS is a Phoenix BIOS 1.07 and the Modem ring detect and IRQ 3 are enabled.
    I tried to check if the RTC driver is working right and I ran the demo program found on the Linux Kernel Documentation/rtc.txt. it works fine and the program is able to detect the RTC interrupt.
    Also, apmsleep does not time out or anything. Just keeps the computer suspended until a key is pressed.
    when I type cat /proc/drivers/rtc it displays something like this:
    rtc_time : 22:34:37
    rtc_date : 2004-02-12
    rtc_epoch : 1900
    alarm : 22:00:25
    DST_enable : no
    BCD : yes
    24hr : yes
    square_wave : no
    alarm_IRQ : no
    update_IRQ : no
    periodic_IRQ : no
    periodic_freq : 1024
    batt_status : okay
    I suspected the parameter alaram_IRQ and tried the ioctl function to enable it, but it still shows no.

    Could anybody help me out?

    Thanks very much.

    Thalapathy

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you sure that your hardware really supports this?

  3. #3
    Linux User
    Join Date
    Nov 2002
    Posts
    420
    Quote Originally Posted by Dolda2000
    Are you sure that your hardware really supports this?
    yes, I checked the processor manual (ZFx86) and it does support power management. The bios also supports power management.
    when I suspend the computer, I notice a significant drop in the power consumption, which means the system does sleep and comes back to normal state on the press of a key.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •