Find the answer to your Linux question:
Results 1 to 3 of 3
Ok, I FINALLY got Linux working, Slackware, which was a real pain. Everything that could have gone wrong, did. So then I decided to compile my own kernel... I got ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    8

    Stupid noob decided to compile his kernel... HELP!


    Ok, I FINALLY got Linux working, Slackware, which was a real pain. Everything that could have gone wrong, did. So then I decided to compile my own kernel... I got the 2.6.17 kernel, went through and tried to pick the correct options, then did,

    make bzImage
    make modules
    make modules_install
    make install

    Woohoo, I say to myself. That wasn't too hard...

    Then, I load it up, and notice Lilo still has only one option.

    The horror hits me... No... what have I done??!?!

    For some reason I thought my old kernel would still be there, but it's not.

    I bight my nails as I hit enter and wait...

    The computer begins to load, goes to a fuzzy screen, and restarts...

    NOOOOOOOOOO!!!! What have I DONE?!?! WHY did I try to install a new kernel?!?! WWwwwwhhhhyyy........

    I tried making lilo.conf point to vmlinuz.old and vmlinuz-ide-2.4.whatever.

    But no, it still just restarts when it tries to load the kernel.

    HEEEELP MEEE! Please... I've spent weeks playing with Linux and it's getting very flustrating. Even after reading every tutorial on the net that I can find, I seem to screw everything up. My last install I ended up locking KDE up, locking it up AGAIN when it was trying to scan the uncleanly mounted disk, and ended up corrupting all my data. Is there anyway I can get my old kernel back?

    EDIT: I mounted my slackware CD and looked around on it, I found a bzImage for bare.i (the kernel the CD uses to boot up) and then moved it to my /boot dir and told lilo to boot it. Again, it didn't work. I don't understand... shouldn't that have worked? What files are edited when "make install" runs?

  2. #2
    Linux User fernape's Avatar
    Join Date
    Dec 2005
    Location
    Holland
    Posts
    301
    Quote Originally Posted by Lone-wolf
    make bzImage
    make modules
    make modules_install
    make install
    AFAIK, with 2.6 series, only make and make modules_install are required. I don't know if the make install overwrites the old kernel with the new one (the bzImage named file). If that is the case, you broke your old kernel.

    Maybe you should think about re-installing. Just a final question: you don't mention anything about the configuration stage... did you type make config or make gconfig? and if it's the case, which options did you select?

    Regards

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    8
    I did,

    make menuconfig

    And left most things alone. I read somewhere that it looks at your current kernel and makes it the same? You just have to edit it if you want to change something or take out all the extras you don't need?

    Anyway, I did a new install, and backed it all up when I got it working so I can screw it up and get it back to a fresh install after about 30 minutes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •