Hi,

I am using CentOS release 3.7 (Final) on my server.

Kernel is Linux 2.6.8.1 #3 SMP

Today i tried to upgrade kernel with yum thinking it will be latest version than what i am having.

But it installed older kernel than the one one i have - 2.4.21-47.EL

I tried compiling from source, but on "make install", i get error

sh /usr/local/src/linux-2.6.17.11/arch/i386/boot/install.sh 2.6.17.11
arch/i386/boot/bzImage System.map "/boot"
No module ata_piix found for kernel 2.6.17.11, aborting.
mkinitrd failed
make[1]: *** [install] Error 1
make: *** [install] Error 2
The server have SATA Hard Disk. I think i need to enable ata_piix module. But i can't find HOW-TO enable this.

Can anyone tell me how to fix error or where i can find latest version of Kernel RPM that work with CentOs 3.7 ?

Thanks,

Yujin