Find the answer to your Linux question:
Results 1 to 7 of 7
I have slackware 10.2, downloaded the latest version of Linux from kernel.org (2.6.17.11) Unpacked it and did make mrproper make xconfig make su make modules_install and copied bzimage to /boot/ ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064

    No network after 2.6 update


    I have slackware 10.2, downloaded the latest version of Linux from kernel.org (2.6.17.11)

    Unpacked it and did

    make mrproper
    make xconfig
    make
    su
    make modules_install
    and copied bzimage to /boot/ as vmlinuz-2


    Not sure if I included the module for networking (which?) or even If I should include it as a module or in the kernel itself

    If is a module, should i load it with modprobe? if so which module? (tulip?)

    I learned all that from a book, but there isn't details about the functions of each module.

    Thanks in advance

    Everything else is working great
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  2. #2
    Linux User fernape's Avatar
    Join Date
    Dec 2005
    Location
    Holland
    Posts
    301
    Networking is a top level menu, so the first you need is activate that. Then, it is possible that you need your specific NIC driver. It can be as a module or merged into the kernel.

    You should know which driver your NIC needs to work.

    Best Regards

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    is this done through qconf?

    I'm not sure about this NIC thing

    I am really new to this kernel things
    So I would aprecciate some detailed instruction for a kernel n00b please.

    thanks in advance
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    I'm not familiar with qconf, so here's basically what to do:

    First off, I don't like modules. Using modules keeps your kernel smaller, I guess, but it's really not an issue for me, so I find it a lot easier to just build it directly into your kernel.

    Anyway, I assume you're using an Ethernet card? You need to go into the xconfig and activate:
    Networking --> Networking support

    You will also want to explore:
    Networking -->Networking options

    In particular, make sure that:
    Networking -->Networking options --> TCP/IP networking
    is enabled.

    Anyway, having enabled that, we need to enable your specific card's support. The cards are all listed under:
    Device drivers --> Network device support --> Ethernet (10 or 100Mbit)
    Read the help for each one and find yours. If you can't (I couldn't), just enable them all .

    Anyway, that should get your kernel support up and running!

  6. #5
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Thanks a lot, I'll try it
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  7. #6
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Almost there, networking worked with your help but I activated nvidiafb with xconfig and my nvidia drivers didn't work so now I am recompiling without nvidiafb.
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  8. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Got it! now everithing works just fine

    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •