Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all, I get the following common error when my system boots: **** Kernel panic: VFS: Unable to mount root fs on 03:05 **** I use SuSE 8.2 with 2.4.20 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4

    initrd + kernel panic


    Hi all,
    I get the following common error when my system boots:

    ****
    Kernel panic: VFS: Unable to mount root fs on 03:05
    ****

    I use SuSE 8.2 with 2.4.20 kernel. The above problem happens after a successful compilation of the specific kernel.

    To be more specific:

    I configured, and compiled successfully the 2.4.20 kernel.

    I want to have a bootsplash screen. So, I complled as part of the kernel the support for the loopback device and the initial ram disk. As far as I know, I have to create an initrd in order to enable the bootsplash screen. I have also compiled in kernel the frame buffer support and the corresponding option for the bootsplash.

    The root fs is on a reiserfs partition. I compilled reiserfs support as a module.

    So, I had to make an initrd which should include reiserfs support, and the bootsplash screen.

    The distribution of SuSE 8.2 uses the script mk_initrd instead of the command mkinitrd. I created the relavant initrd by typing:

    # mk_initrd -k /boot/mykernel -i /boot/myinitrd -s 1024x768

    The output was:
    ******
    using "/dev/hda5" as root device (mounted on "/" as "reiserfs")

    creating initrd "/boot/myinitrd" for kernel "/boot/mykernel"
    (version 2.4.20-athlon)
    - insmod reiserfs (kernel/fs/reiserfs/reiserfs.o)
    - splash picture (1024x76
    ******
    I made a new option in the boot loader (grub) and changed the /boot/grub/menu.lst. Here, is my grub configuration:

    *********
    default 0
    gfxmenu (hd0,4)/boot/message
    timeout 5

    title linux
    kernel (hd0,4)/boot/vmlinuz root=/dev/hda5 vga=0x317 splash=silent showopts splash=1
    initrd (hd0,4)/boot/initrd

    title MyKernel
    kernel (hd0,4)/boot/mykernel vga=791 splash=1 showopts splash=silent root=/dev/hda5
    initrd (hd0,4)/boot/myinitrd
    ***********

    When I boot I get the kernel panic I mention at the beginning of this post.

    I notice that I can boot if I compile in kernel the reiserfs support
    rather than module.

    Any suggestions??
    Thanks in advance...
    Kostis

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    I guess you would need to have reiserfs support not compiled as a module, but baked into the kernel. Give that a try and tell us how it went.

    Good luck

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    I have already tried! The same problem!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Are you compiling all the IDE stuff into the kernel directly?

  6. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    I do...!

  7. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    I did it...!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •