Find the answer to your Linux question:
Results 1 to 5 of 5
the weirdest thing.. i have a P4 CPU in my machine. it has hyper threading enabled (it shows 'ht'-flag in /proc/cpuinfo, x86info and dmidecode). but it will not enable hyperthreading. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! brugh's Avatar
    Join Date
    Oct 2006
    Posts
    3

    Unhappy hyper threading is disabled.


    the weirdest thing.. i have a P4 CPU in my machine. it has hyper threading enabled (it shows 'ht'-flag in /proc/cpuinfo, x86info and dmidecode). but it will not enable hyperthreading. /var/log/messages shows kernel: Hyper-threading is disabled at boottime. i boot a SMP kernel, latest centos version (i think that's 2.6.9-42.0.3.ELsmp

    i looked at the kernel code and see that the message can only appear if the kernel at least tries to detect hyperthreading so i know i boot the right kernel. but why won't it show 2 processors in /proc/cpuinfo, or top, or anywhere.. is it a kernel HT bug or a BIOS bug? is there anything i need to paste here for people to look at?
    please help

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    32
    Do you have acpi support enabled? also acpi=ht as a boot option may help if so.

  3. #3
    Just Joined! brugh's Avatar
    Join Date
    Oct 2006
    Posts
    3
    Quote Originally Posted by gettyUp
    Do you have acpi support enabled? also acpi=ht as a boot option may help if so.
    bios says i have acpi enabled. i'll try that option (thought i tried the lot of 'm since i checked the kernelsource) and will let you know.

    here's some snippets from dmesg:
    ...
    ACPI: Processor [CPU0] (supports C1, 8 throttling states)
    ...
    ACPI: (supports S0 S1 S3 S4 S5)
    ACPI wakeup devices:
    PCI0 HUB COM1 USB1 USB2 USB3 USB4 EUSB PBTN
    ...

    and from /var/log/messages:
    ...
    Oct 26 20:21:59 lnx kernel: CPU: Trace cache: 12K uops, L1 D cache: 16K
    Oct 26 20:21:59 lnx kernel: CPU: L2 cache: 1024K
    Oct 26 20:21:59 lnx kernel: CPU: Hyper-Threading is disabled
    Oct 26 20:21:59 lnx kernel: Intel machine check architecture supported.
    Oct 26 20:21:59 lnx kernel: Intel machine check reporting enabled on CPU#0.
    Oct 26 20:21:59 lnx kernel: CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
    Oct 26 20:21:59 lnx kernel: CPU0: Thermal monitoring enabled
    Oct 26 20:21:59 lnx kernel: Enabling fast FPU save and restore... done.
    Oct 26 20:21:59 lnx kernel: Enabling unmasked SIMD FPU exception support... done.
    Oct 26 20:21:59 lnx kernel: Checking 'hlt' instruction... OK.
    Oct 26 20:21:59 lnx kernel: CPU0: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 01
    Oct 26 20:21:59 lnx kernel: per-CPU timeslice cutoff: 2925.18 usecs.
    ...

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    32
    I know its not CentOS docs, but I would check your kernel configs and see if you have any of these options missing.

    http://gentoo-wiki.com/ACPI_Intel_865_and_875

  5. #5
    Just Joined! brugh's Avatar
    Join Date
    Oct 2006
    Posts
    3

    Angry

    Quote Originally Posted by gettyUp
    I know its not CentOS docs, but I would check your kernel configs and see if you have any of these options missing.

    http://gentoo-wiki.com/ACPI_Intel_865_and_875
    hmm that looked like a good option so i tried it. recompiled kernel, new initrd, but still only one CPU. *huge disapointed sigh*

    then i did a grep 'acpi=' on arch/i386/kernel/setup.c for any options i hadn't tried yet:

    else if (!memcmp(from, "acpi=off", ) {
    else if (!memcmp(from, "acpi=force", 10)) {
    else if (!memcmp(from, "acpi=strict", 11)) {
    else if (!memcmp(from, "acpi=ht", 7)) {
    else if (!memcmp(from, "pci=noacpi", 10)) {
    else if (!memcmp(from, "acpi=noirq", 10)) {
    else if (!memcmp(from, "acpi_sci=edge", 13))
    else if (!memcmp(from, "acpi_sci=level", 14))
    else if (!memcmp(from, "acpi_sci=high", 13))
    else if (!memcmp(from, "acpi_sci=low", 12))
    else if (!memcmp(from, "acpi_skip_timer_override", 24))

    tried almost all of them.. no hyperthreading.... how come when i put a windows CD in there it shows me 2 processors and with linux there's no way to get it to work! i hate it when that happens. only thing i can think of is to try an original kernel.org kernel. but CentOS uses a 2.6.9 with a lot of own patches which i would really want to use, specially since software i use on there is ready-built for redhat EL4. please advice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •