Hi everybody,

I am using FC2 with kernel version 2.6.5-1.358

I am unable to insert iptable_nat module into kenrel.

# modprobe iptable_nat
FATAL: Error inserting iptable_nat (/lib/modules/2.6.5-1.358/kernel/net/ipv4/netfilter/iptable_nat.ko): Unknown symbol in module, or unknown parameter (see dmesg)
# modprobe ipt_state
FATAL: Error inserting ipt_state (/lib/modules/2.6.5-1.358/kernel/net/ipv4/netfilter/ipt_state.ko): Unknown symbol in module, or unknown parameter (see dmesg)

#dmesg |grep nat
ICH4: not 100% native mode: will probe irqs later
iptable_nat: Unknown symbol ip_ct_selective_cleanup
iptable_nat: Unknown symbol invert_tuplepr
iptable_nat: Unknown symbol ip_ct_gather_frags
iptable_nat: Unknown symbol ip_conntrack_untracked
iptable_nat: Unknown symbol ip_conntrack_get
iptable_nat: Unknown symbol ip_conntrack_htable_size
iptable_nat: Unknown symbol ip_conntrack_destroyed
iptable_nat: Unknown symbol __ip_ct_find_proto
iptable_nat: Unknown symbol need_ip_conntrack
iptable_nat: Unknown symbol ip_conntrack_tuple_taken
iptable_nat: Unknown symbol ip_conntrack_alter_reply
iptable_nat: Unknown symbol ip_ct_selective_cleanup
iptable_nat: Unknown symbol invert_tuplepr
iptable_nat: Unknown symbol ip_ct_gather_frags
iptable_nat: Unknown symbol ip_conntrack_untracked
iptable_nat: Unknown symbol ip_conntrack_get
iptable_nat: Unknown symbol ip_conntrack_htable_size
iptable_nat: Unknown symbol ip_conntrack_destroyed
iptable_nat: Unknown symbol __ip_ct_find_proto
iptable_nat: Unknown symbol need_ip_conntrack
iptable_nat: Unknown symbol ip_conntrack_tuple_taken
iptable_nat: Unknown symbol ip_conntrack_alter_reply
iptable_nat: Unknown symbol ip_ct_selective_cleanup
iptable_nat: Unknown symbol invert_tuplepr
iptable_nat: Unknown symbol ip_ct_gather_frags
iptable_nat: Unknown symbol ip_conntrack_untracked
iptable_nat: Unknown symbol ip_conntrack_get
iptable_nat: Unknown symbol ip_conntrack_htable_size
iptable_nat: Unknown symbol ip_conntrack_destroyed
iptable_nat: Unknown symbol __ip_ct_find_proto
iptable_nat: Unknown symbol need_ip_conntrack
iptable_nat: Unknown symbol ip_conntrack_tuple_taken
iptable_nat: Unknown symbol ip_conntrack_alter_reply

But the is getting loaded while rebooting.
But when I restart the iptables unable to load the module.

# /etc/init.d/iptables restart
Flushing firewall rules: [ OK ]
Setting chains to policy ACCEPT: mangle filter [ OK ]
Unloading iptables modules: [FAILED]
Applying iptables firewall rules: iptables-restore v1.2.9: iptables-restore: unable to initializetable 'nat'

Error occurred at line: 11
Try `iptables-restore -h' or 'iptables-restore --help' for more information.
[FAILED]


I am using this as internet gateway through Natting.
Please help me out to resolve this issue.

Thanks & Regards,
Mummaneni.