Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    2.6.18 & 2.6.19 can't tell time

    I'm using a basic debian etch install. But I wanted to upgrade beyond the 2.6.17 kernel. First I tried grabbing 2.6.18 from the sid repositories. While booted to this kernel every one second my clock moves forward 1.5 - 5 seconds. So I downloaded and compiled 2.6.18 from Same thing. Downloaded the 2.6.18 source from debian and compiled... same thing. Finally I've d/led and compiled 2.6.19 from and that did it too.

    All I have to do to get my clock to slow back down is to reboot to the 2.6.17 kernel.

    I didn't even change the config, I tried changing the config enough to switch it from the default 486 to k6/k6II/k6III and that had no effect.

    Is this actually the kernel, or could it be some daemon I have running? HAL, ACPId, apache, dbus, udev, I mean basic stuff, nothing I don't have running under 2.6.17 obviously.

    hardware is AMD K6-2 450MHz, 640MB RAM, ASUS P5A mainboard.

  2. #2
    Random acts of experimentation discovered the problem for me: ACPId and Powersaved.

    Removal of both of these followed by a full reboot fixes the problem. If either is installed the clock immediately speeds up until you remove them and reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts