Find the answer to your Linux question:
Results 1 to 2 of 2
Hi i am having trouble with getting kernel-2.6.3-7mdk to mount the vfat fs: when i boot the above kernel i see this during boot-up: mount: wrong fs type or bad ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    Australia
    Posts
    2

    cannot mount vfat fs using 2.6.3-7mdk


    Hi i am having trouble with getting kernel-2.6.3-7mdk to mount the vfat fs:

    when i boot the above kernel i see this during boot-up:

    mount: wrong fs type or bad option, bad superblock, or too many mounted filesystems /dev/hdc1

    and the same for /dev/hda

    hdc1 is my winXP pro usinf fat32 - hda is my dload dir using fat32.

    I have xp on my main hdd, and mandrake 9.1 on my second hdd.

    using mandrake 9.1 with kernel 2.4.21-0.13mdk: the reason i want the latter kernel is for the ATAPI-IDE cd-rw option instead of using scsi-emulation.

    Cheers
    LiNuts

  2. #2
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Stockholm, Sweden
    Posts
    130

    tip of the day

    1 ) Make sure you have built the kernel with vfat support
    2 ) Make sure you have a line similar to

    "/dev/hdc1 /mnt/winxp vfat defaults 0 0"

    in your fstab (you have to manually create /mnt/winxp or whatever mountpoint you would like)

    3 ) Post your fstab next time you ask the question

    In my experience though, when it says :
    "wrong fs type or bad option, bad superblock, or too many mounted filesystems" its probably because you tried to mount the wrong filesystem or as the wrong type. I have actaully NEVER mounted to many file systems (don't know the upper limit, but I think it is pretty high)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •