Find the answer to your Linux question:
Results 1 to 2 of 2
I have a revB i-mac on which I installed Yellow Dog 4.0. The install went fine. I decided to run the i-mac as a linux appliance so I did not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Monitor display not working in console, works in X


    I have a revB i-mac on which I installed Yellow Dog 4.0. The install went fine. I decided to run the i-mac as a linux appliance so I did not need the monitor. I already have a spare monitor sitting around for other servers so I soldered together a 15pin macintosh video to VGA converter cable to use. After plugging in the monitor, it displayed fine during the BIOS start-up, and through the bootloader. and even the beginning of the kernel load. However, once tux appeared in the top left corner of the screen, the monitor displayed 4 columns, with succesive rows in successive columns.

    I played around with the XF86Config and was able to get X windows displaying perfectly with the following stanza:

    Section "Monitor"

    # DisplaySize 270 200
    # HorizSync 60.0 - 60.0
    # VertRefresh 75.0 - 117.0
    Identifier "Monitor0"
    ModelName "Acer"
    HorizSync 28.0 - 50.0
    VertRefresh 56.0 - 76.0
    Option "DPMS"
    EndSection

    now the only thing that does not display correctly is the console. Does anyone know what must be done to tell the kernel or framebuffer how to interact with the monitor in the way that X uses the XF86Config file? I've posted this question to several message boards with no response and can't find anything on the web. I've also tried the framebuffer user's list with no response or suggestions.

    Thanks,
    Kevin Nowaczyk

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    ofonly

    To answer my own question. I went to install debian over yellowdog, and it suggested typing install video=ofonly. That seems to be the fix. So I can either add video=ofonly to yaboot.conf file or just install debian, which is probably a better distro anyways.

    Kevin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •