Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 22 of 22
hiii friends i too get the same errror while compiling a kernel module in suse 10.1 whats the solution for it?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    same error


    hiii friends
    i too get the same errror while compiling a kernel module in suse 10.1
    whats the solution for it?

  2. #22
    Just Joined!
    Join Date
    Aug 2007
    Posts
    8
    [root@localhost hello]# insmod hello.ko
    insmod: error inserting 'hello.ko': -1 Invalid module format
    1.why i got -1 when inserting the module because i compiled the module with 2.6.20 for which i have source & tried to insmod form a precompiled 2.6.15 kernel(I HAVE DOWNLOADED 2.6.20 FROM KERNEL.ORG)
    2.see my make it made the build to enter /usr/src/2.6.20 source ..where is ur make entering .....not able to luk for source code at all how will it compile
    You must use your module only for the kernel, for which it has been compiled. So get .config for your 2.6.15 kernel, compile 2.6.20 with it and try to load hello.ko with 2.6.20.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •