Find the answer to your Linux question:
Results 1 to 4 of 4
Hello people, I have written a simple makefile for a simple module , I am getting the following error make -C /lib/modules/2.6.15-28-amd64-xeon/build M= modules make[1]: Entering directory `/usr/src/linux-headers-2.6.15-28-amd64-xeon' CHK include/linux/version.h ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! vijay_kernel's Avatar
    Join Date
    Apr 2007
    Posts
    77

    Makefile error


    Hello people,

    I have written a simple makefile for a simple module , I am getting the following error


    make -C /lib/modules/2.6.15-28-amd64-xeon/build M= modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.15-28-amd64-xeon'
    CHK include/linux/version.h
    make[2]: *** No rule to make target `arch/x86_64/kernel/../../i386/kernel/cpuid.o', needed by `arch/x86_64/kernel/msr.o'. Stop.make[1]: *** [arch/x86_64/kernel] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.15-28-amd64-xeon'
    make: *** [all] Error 2


    Any help would be appreciated .......

    Thanks in advance.

  2. #2
    Just Joined! vijay_kernel's Avatar
    Join Date
    Apr 2007
    Posts
    77
    I have solved the problem .

    Cheers...

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    1
    How did you solve it?

    I have the same problem.

  4. #4
    Just Joined! vijay_kernel's Avatar
    Join Date
    Apr 2007
    Posts
    77
    hey,

    Just check the spelling mistake in your source file or Makefile.
    Because I had the same problem , I corrected it , it worked.

    Cheers,
    Vijay_kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •