Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
I am currently running 2.6.20 kernel, and I have had this issue for a long time now. It appeared when I upgarded for 2.4.27 to the 2.6 kernel. Currently the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3

    Thanks for the info.


    I am currently running 2.6.20 kernel, and I have had this issue for a long time now. It appeared when I upgarded for 2.4.27 to the 2.6 kernel. Currently the only distro that I know is running this kernel 2.4 is Debian Sarge, and I don't have the restart issue. I can revert back to Sarge at the expense of newer updates. But, for now I'm staying with 2.6 kernel. I just want to know if there is a major difference in ACPI or APM, between the two. Maybe I can build a custom kernel and try it.

  2. #12
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Can you try booting up the 2.6 kernel and running the following
    Code:
    dmesg |grep -i acpi |tee ~/acpitest.log
    sudo grep -ir acpi /var/log/* |tmp ~/acpitest2.log
    Enter root password when prompted and post the contents of the the output files back here.

  3. #13
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3

    Here is the first test.

    BIOS-e820: 000000003ff70000 - 000000003ff7a000 (ACPI data)
    BIOS-e820: 000000003ff7a000 - 000000003ff80000 (ACPI NVS)
    ACPI: RSDP (v000 TOSCPL ) @ 0x000f6c00
    ACPI: RSDT (v001 TOSCPL RSDT 0x06040000 LTP 0x00000000) @ 0x3ff73269
    ACPI: FADT (v001 TOSCPL SPRGDALE 0x06040000 PTL 0x00000003) @ 0x3ff79ef7
    ACPI: MADT (v001 PTLTD APIC 0x06040000 LTP 0x00000000) @ 0x3ff79f6b
    ACPI: SSDT (v001 PTLTD ACPIHT 0x06040000 LTP 0x00000001) @ 0x3ff79fc9
    ACPI: DSDT (v001 TOSCPL SPRGDALE 0x06040000 MSFT 0x0100000e) @ 0x00000000
    ACPI: PM-Timer IO Port: 0x1008
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
    ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    Using ACPI for processor (LAPIC) configuration information
    Kernel command line: BOOT_IMAGE=PCLinuxOS root=/dev/hda1 splash=silent acpi=ht vga=788
    ACPI: Interpreter disabled.
    pnp: PnP ACPI: disabled
    PCI quirk: region 1000-107f claimed by ICH4 ACPI/GPIO/TCO
    Yenta: check your BIOS CardBus, BIOS IRQ or ACPI settings.
    Yenta: check your BIOS CardBus, BIOS IRQ or ACPI settings.
    NVRM: failed to register with the ACPI subsystem!
    NVRM: failed to register with the ACPI subsystem!
    NVRM: failed to register with the ACPI subsystem!


    The second test says this "bash: tmp: command not found" . I can't sudo, I'm on PCLinuxOS, but I did become root on the second test. Thanks for the help.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Aug 2006
    Location
    india
    Posts
    57
    Luking into the header for your query DIFFERENCE BETWEEN 2.6,2.4

    major change in kernel is context switching time ,jiffies r made 1000 from 100 in 2.4 so instead of 10ms switch u will get interrupt 0x80 every 1ms

    But this is no way related to your problem

    1.Did u installed stable linux (U can get them from The Linux Kernel Archives)
    2.U do make menuconfig or make xconfig to luk into your settings
    3.when u do "make install" to get ur kernel to boot see ur not facing any problems

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •