I have a feeling someone is going to tell me to install something for my other thread (sharing files in DSL). So can someone tell me what to do when I try to apt-get install something and I get messages like "depends: perl-base (=5.6.1-8.9) but 5.8.0-18 is to be installed"? How do I get the version I need?

Also I keep seeing dependencies and when I try to install the dependency it says something like "newest version already installed".

Thanks