Find the answer to your Linux question:
Results 1 to 5 of 5
I've just started a new job and they have this system with Windows 2003 server. The person who left didn't tell them the admin password for the system, so I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    3

    Knoppix and Win2003 Server


    I've just started a new job and they have this system with Windows 2003 server. The person who left didn't tell them the admin password for the system, so I booted Knoppix 5.0 (5.1 had a problem, may be the CD) and can get into the system with no problem. However, when I do to change the read/write mode to write, the hard drive becomes unmounted.

    Anyone know if win2k3 server has a special NTFS format, or why I can't change to the write mode?

    I can't get to chntpw and change the password if I can't change to write mode on /mnt/hda1.

    Any advice appreciated.

    Thanks,

    Mark

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Execute this
    Code:
    mount -t ntfs-3g /dev/hda1  /mnt/hda1 -o defaults,umask=0
    You will have read/write access in /mnt/hda1.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    3
    Quote Originally Posted by devils_casper View Post
    Hi and Welcome !

    Execute this
    Code:
    mount -t ntfs-3g /dev/hda1  /mnt/hda1 -o defaults,umask=0
    You will have read/write access in /mnt/hda1.
    Thanks for the suggestion, but it returns an error -
    mount: unknown filesystem type 'ntfs-3g'

    Any other advice?

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It means ntfs-3g package is not available in Knoppix 5.0 and you will not able to write in NTFS partitions. If your machine has internet access then install ntfs-3g package.
    Code:
    su 
    apt-get install ntfs-3g
    Execute mount command again.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Oct 2007
    Posts
    3
    I was able to get knoppix 5.1 and booted on the system. But, here's a problem. I was never able to shut down the Win2003 Server box because the person before me hadn't left the admin password, which is the reason I'm trying to do this with Knoppix and chntpw, so the filesystem on the box is unclean. I'm using the following command to try to mount the filesystem:

    mount -t ntfs-3g /dev/hda1 /mnt/hda1 -o force,default,umask=0

    but I keep getting the error msg:

    WARNING: Dirty volume mount was forced by the 'force' mount option.
    fusermount: mountpoint is not empty
    fusermount: if you are sure this is safe, use the 'nonempty' mount option
    Failed to create FUSE mount point: No such file or directory
    Retry to create FUSE mount point ...
    FATAL: Module fuse not found.
    fusermount: mountpoint is not empty
    fusermount: if you are sure this is safe, use the 'nonempty' mount option
    Failed to create FUSE mount point: No such file or directory
    Unmounting /dev/hda1 ()

    I've looked all over in man 8 mount, -h, etc, and can't find a parameter for 'nonempty' and can't get the filesystem to mount.

    Any further suggestions?

    Thanks.

    Mark

    update: I created a new subdirectory ntfs under /mnt and that allowed me to mount the filesystem.

    However, Knoppix isn't finding the SAM registry hive where the passwords are kept. I'll look on the MS knowledge base to see if they changed the location from XP.

    Thanks all.

    Mark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •