Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all. i am using knoppix 5.0 live cd. I tried deleting a file in Windows(tm) system 32 (I really have to delete it ) using the terminal shell but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    9

    Question unable to reverse the attributes of a file.


    Hi all.

    i am using knoppix 5.0 live cd. I tried deleting a file in Windows(tm) system 32 (I really have to delete it) using the terminal shell but when i use the command

    rm logoff.exe

    it prints out "rm: cannot remove 'logoff.exe' : read-only file system".

    i have tried to use

    attr -r logoff.exe

    but it prints out a message implying i obviously don't know how to use "attr". please help me remove the file.

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    2

    Read-Only filesystem

    Hallo

    The message you get says read-only filesystem. In other words the whole windoze file system is mounted as readonly. Therefore you cannot change anything on the filesystem.

    This is typical of NTFS filesystems. Linux by default mounts them as readonly since MS will not release all the intricacies of their filesystems inner workings linux cannot guaranty that it can modify it safely.

    You could recompile your own linux kernel with read-write NTFS support, but as said, that implicates a risk. Over and above that I assume you might not want to since you are using a live CD.

    Knapie

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    9

    Thumbs up thanks alot

    Thanks alot. i really needed to delete that file but it's okay, u've taught me things i did not know. Thanks again.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    There is no need to recompile kernel. You can enable NTFS write access through ntfs-3g.
    Open Synaptic Package Manager and search for ntfs-3g. Install it and mount NTFS partition again.
    You can use PartedMagic LiveCD too. Its a Partition Manger and ntfs-3g package is pre-installed in it.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Feb 2008
    Posts
    9

    Thumbs up Thanks you guys...

    i have solved the problem using your info and Knapie's info.
    As Knapie says that when linux mounts a partition, it is read only, and when you say remount it again, i have realized that if the partition was mounted by a user, say an administrator, then, the file would not be read-only...
    so i used:

    umount -t ntfs /dev/hda1 /media/hda1

    and this unmounted the harddisk

    and mounted using

    mount -t ntfs /dev/hda1 /media/hda1

    and just as expected, all the files were not read-only!!

    Thanks so much guys, i could not have done it without you. You have taught me alot!!!! you guys are totally cool like ->

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •