Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, ive never used Linux before, but today I took out my old computer and decided to do something with it. I have a 512MB USB drive, that I put ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    1

    Booting from USB problems with DSL


    Hi, ive never used Linux before, but today I took out my old computer and decided to do something with it. I have a 512MB USB drive, that I put all the files on correctly (to my knowledge) for Damn Small Linux. It goes fine, but when it starts up it says "Cannot find Knoppix file system" and sends me to a prompt. Ive tried selecting "advanced" from the boot options and answering no to everything. It finds the knoppix file system, but after awhile it goes to a screen that says

    giving up
    xinit: No such file or directory (errno 2): unable to connect to X server
    xinit: no such process (errno 3): Server error.
    dsl@tty1[dsl]$

    I only have my USB drive connected, but no hard drive. I have enough ram (1 and 3/4 gigs). Can someone help me?

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Welcome to the forums kliff

    Did you do the install on the machine you are trying to boot ... without the hard drive in? Does the machine support USB boot or are you getting it to boot from another device? Which install options have you tried to put DSL on the USB drive? What x server display setups have you tried? Does the live CD drive the graphics display properly?

    Ed: you might also find this useful.

  3. #3
    mrX
    mrX is offline
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1
    I had similar issue and tried using dsl xsetup
    good luck

  4. #4
    Just Joined!
    Join Date
    Feb 2009
    Posts
    6
    Installed dsl on my 2Gb Kingston Data Traveler. I got it to boot to the dsl os but it randomly locks up and freezes. This first happened when it was loading. Then after a forced shutdown it loaded fine, the within 30 seconds inside linux it locked up. It will do this when ever I move the mouse and start to do something. If it just sets there its fine but as soon as something starts going down....its done!

    New to linux and booting USBs. I also did not look through 25 pages of this thread to see if this has been discussed.

    Hope someone can help me.

    Comp specs:
    Dell Inspiron 1525 laptop
    Vista home premium
    2Gb RAM, Intel pentium Dual-Core 1.73Ghz

    Need anymore info tell me.

    I also tryed it on another comp, and it did the same thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •