Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unable to get internet connection

    I am new to linux so I am just trying out Knoppix. Everything seems to be working fine except I can't get an internet connection. I am using a HP laptop. It has a NVIDIA nForce Networking Controller and a Broadcom 802.11a/b/g WLAN. I'm hoping at least one of them is supported. I am connecting to a router with DHCP enabled. I've tried a few things like "ifconfig eth0 up", running netcardconfig and pinging my router but nothing. Here are a few command outputs:

    uname -a
    Linux Knoppix 2.6.19 #7 SMP PREEMPT Sun Dec 17 22:01:07 CET 2006 i686 GNU/Linux

    lspci -vv | grep -i ethernet
    00:0a.0 Ethernet controller: nVidia Corporation Unknown device 054c (rev a2)

    dmesg | grep eth
    eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)

    ifconfig -a -v
    eth0 Link encap:UNSPEC HWaddr 00-24-1B-00-07-E6-56-00-00-00-00-00-00-00-00-00
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:8 dropped:8 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:42 errors:0 dropped:0 overruns:0 frame:0
    TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2100 (2.0 KiB) TX bytes:2100 (2.0 KiB)

    lspci -vv | grep -i broad
    03:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 02)

    lo no wireless extensions.

    eth0 no wireless extensions.

    Any help is appreciated.

  2. #2
    You are setting up a wireless interface.
    But eth0 is a wired interface. You will have to deconnect that interface. If you have KDE/KMenu you can do the settings there.

    You should be able do configure your interface via a few applications in your menu bar.

    The output is ońly showing, that other interfaces are hindering you to get connected with your wireless setup.

    You will need to set your system for wlan, but not for eth0, and not for eth1.

    Maybe ath0 might work, but it is probably wlan.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts