Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
I haven't done it yet, but I thought I'd write out what I think is right and make sure it is first: sudo mkdir /files2 sudo unmount /dev/hda1 sudo ntfs-3g ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2008
    Posts
    13

    I haven't done it yet, but I thought I'd write out what I think is right and make sure it is first:

    sudo mkdir /files2

    sudo unmount /dev/hda1

    sudo ntfs-3g /dev/hda1 /files2

    cp -a /media/sda1/Albums /media/hda1/files2

    ls -R files2
    With the Albums folder on sda1 being the folder I want to copy over to hda1.

    Is that right? I'm not sure if I've got the path right for the cp part.

  2. #12
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    From your last post ...
    Code:
    sudo mkdir /files2
    sudo umount /dev/hda1
    it should be umount not unmount

    Code:
    sudo ntfs-3g /dev/hda1 /files2
    cp -a /media/sda1/Albums /files2
    ls -R /files2
    path is /files2

    I think that should do what you want. If the files are not copied and you get permissions errors then add sudo in front of the cp and ls commands - but try as a regular user first.

  3. #13
    Just Joined!
    Join Date
    Oct 2008
    Posts
    13
    I tried it, and it transferred the first 3 albums in the Albums folder, then I guess it must have stalled.

    The first time I tried, it started transferring then it was prompting me to overwrite. There's an Albums folder on my hda1 drive too, so I guessed that was why, as even though I don't have the same albums in there, I guess it must have been confused about the main folder name, as opposed to the sub-folders. I overwrote to start with, then at the end I started typing no. It seemed to do the 3rd album then stall. I decided to rename the Albums folder on hda1, Albums2.

    I then restarted and tried again, and it transferred the exact same 3 albums then stalled.

    I thought maybe if I did them 1 folder at a time it'd work, but I tried this command:

    knoppix@Knoppix:~$ ls -R /media/sda1/Albums
    And it's stalled. It's got to that position where there's just a white block and it doesn't say "knoppix@Knoppix".

    Now I can't open the sda1 drive in the GUI either, which is what happened before after it stalled, when I was trying to transfer the files with the GUI.

    Any more ideas? I really appreciate the help.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    I'd try restarting the system and copy subfolders ... go through the same mount process but this time run ls /media/sda1/Albums and try individual folders. Hopefully you should be able to copy everything except 1 or 2 folders. As I said in a previous post the best approach is recover/backup as much data as you can before you start running disk/data recovery utilities ... this will help you minimise any data loss.

    It's also worth getting any unique data you may have off the drive first ... things like familiy photos, documents you have written etc and come back to the music stuff after.

    You might find a disk utility cures your problems ... but then again it could trash the whole drive Once you have all the data you can get off the drive then you can try and work out if its a hardware problem and try to fix things to recover the rest of your data.

    You may find something on the forums here that will help, otherwise you could give something like ubcd a go.

  6. #15
    Just Joined!
    Join Date
    Oct 2008
    Posts
    13
    I tried running ls /media/sda1/Albums but it just froze again. I think the contents is too big to handle, so I might just have to ignore that for now, and like you said, deal with the other stuff first. Oh, and I noticed that certain files seem to make the transfer process stall. There's been 4 files so far that I haven't been able to transfer, even just on their own. It's really random though, I'll transfer pretty much the whole folder, then I'll get to 1 file and it will just stall it. Yet with those 3 albums I managed to transfer, it came up saying 1 of the files was corrupt, and it still continued transferring even after that. It's really strange.

    Also, I realised that I've never mentioned how my hard drive crashed in the first place. That could be helpful in sorting it, so here's a post I made about it on another forum when it initally crashed and before I tried Knoppix:

    I logged on to my computer today, I was on it for quite a while, doing everything as normal, there were no problems at all and there haven't been for ages. Then my computer suddenly froze so I restarted it.

    When it came back on it was telling me I had a disk boot failure and to insert the system disk. I called my friend who had my disk, and he said he could come over with it. Turned the computer off, left it for about 20 minutes, then when I turned it back on it wasn't coming up with that error but there was some other problem that I don't remember, it was minor though. I turned it off and went out, then came back, turned it on and it worked. I've dealt with computers enough that I knew not to trust it, so I wasn't too hopeful. I was on it for a couple of hours, then I turned it off to do something.

    I turned it back on and it said there was a problem with the shut down, and it asked me what options to choose. I chose "Start Windows Normally", but it went to the XP logo screen and then restarted. No matter what option I tried, it kept restarting.

    I changed the boot mode to CD, and booted with my XP disk. I tried going into the Repair mode and using the chkdsk /r method, but it got to 50% and then stopped, saying something was unrecoverable. I tried FIXBOOT and it said the boot partition was corrupt and it created a new one. I restarted and it was still stuck in this endless loop of restarting.

    I then pressed F8 and it brought up the advanced options screen or whatever it's called, and I selected "Disable automatic restart on system failure", that's when it brought up the UNMOUNTABLE_BOOT_VOLUME blue screen of death.

    I've been trying to sort it for hours and I've had no luck yet. I've searched all over the internet and tried various methods, I've tried reseating the hardware, I've tried only plugging the monitor, keyboard and mouse in, I've tried everything I can personally think of.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •