Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Ok I am fairly new to linux. I don't know much but I am in love with it although I always seem to have problems. Ok so I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    18

    Two problems: Sound and Flash


    Ok I am fairly new to linux. I don't know much but I am in love with it although I always seem to have problems. Ok so I have a Sound Blaster Audigy SE, and it is detected at boot, but I hear no sound, I tried messing with the volume, I enabled sound through the control center, but no sound. Here is my lspci readout:

    00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge (rev 03)
    00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12)
    00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
    00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 12)
    00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 12)
    00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 12)
    01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6200] (rev a1)
    02:0b.0 Multimedia audio controller: Creative Labs SB Audigy LS
    02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    I just not realized that it is detecting my Audigy SE as Audigy LS, so how do I fix that?

    ------------
    Also I cant get flash to install. The automatic install through the iceweasel plugin finder doesnt work and I haven't been able to manually install it because I cant find the mozilla install dir that the install keeps asking for, which I thought was /usr/lbin/mozilla. I am running off a CD by the way with the latest version.

    thanks for any help.

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    11
    regarding flash, i recommend just extracting the flash archive, and copying the plugin into the directory for your browser.

    try /usr/lib/flashplugin (some distros symlink their plugin to this location, so it's easier for multiple browsers to share the plugin. makes updating easier, too.)

    otherwise, /usr/lib/mozilla-firefox or /usr/lib/iceweasel

    as far as sound goes, too much work for me to explain, you will probably need to blacklist crap

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    18
    It wont let me write to any location >.>

  4. #4
    Just Joined!
    Join Date
    Dec 2008
    Posts
    11
    ah, you will probably need root priviledges, ie. su or sudo

  5. #5
    Just Joined!
    Join Date
    Nov 2008
    Posts
    18
    I am logged in as root, I set a root password already.

  6. #6
    Just Joined!
    Join Date
    Dec 2008
    Posts
    11
    ah, i overlooked something. you are using knoppix, a livecd. that directory is probably mounted read only. if you want good support on a livecd, www.zenwalk.org - Ever tried zen computing? has a good one with flash 9 preinstalled. perhaps it might solve your sound issues as well.

  7. #7
    Just Joined!
    Join Date
    Nov 2008
    Posts
    18
    I don't understand, I have installed flash and java before on this livecd. And the system should not be "read-only" it writes it to RAM so I should be able to write to it.

  8. #8
    Just Joined!
    Join Date
    Dec 2008
    Posts
    11
    yeah, i figured it should be running from a ramdisk, but it being read-only is the only logical reason i could come up with for why a root account wouldn't be able to write to it

  9. #9
    Just Joined!
    Join Date
    Nov 2008
    Posts
    18
    My brother who knows more about linux than I do showed me where the plugins are stored, and I realized that when I did install it through konsole it comes up there, but iceweasel tells me it is not installed when I tried going to a flash website, even though the plugins are in the correct folders. It is weird.

  10. #10
    Just Joined!
    Join Date
    May 2005
    Posts
    48
    You should have only needed root privileges, however, use chmod 766 on the file and
    cp libflashplayer.so /usr/lib/iceweasel/plugins
    or
    cp libflashplayer.so /home/knoppix/.mozilla/plugins

    The CD version can use the flash 9 and not the flash 10, BTW.
    So some sites that need a #10 is a no go.

    alsa sound
    Use alsaconf to install the alsa driver snd-ca0106
    either configure alsamixer and alsactl store <card #> Check if you need Digital/Analog switch on.
    or config kmix
    gl

    PS. Check out pclinuxos it can use the flash 10. Next year there's an '09 version coming.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •