Find the answer to your Linux question:
Results 1 to 3 of 3
As usual I went ahead like a blunderbus and did lots of things I had no idea what I was doing. Anyway I had a problem accessing the internal drive ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3

    usb drive wont mount (input/output error)


    As usual I went ahead like a blunderbus and did lots of things I had no idea what I was doing.
    Anyway I had a problem accessing the internal drive on my laptop and was getting the same error as the OP:

    Unable to mount device
    Error org.freedesktop.Hal.Device.Volume.UnknownFailure

    So tried to mount it various ways and then used the command:

    mount -t ntfs-3g /dev/sda1 /media/sda1 -o force

    which worked fine.

    Step 2:

    Tried to get the USB hard drive to be recognised so I could copy the data off the drive, so again:

    mount -t ntfs-3g /dev/sdb /media/sdb -o force

    which worked. Copied all the information off the internal drive and then put the usb drive into my windows machine (didnt dismount). When added it recognises a usb mass storage device but doesnt appear in my computer. Also I tried remounting it in knoppix but I get the error 'input/output error. NTFS is either inconsistent, or you have hardware faults......'

    any ideas?

  2. #2
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3
    can anyone help me. im only 12 and i could end up coding some crucial linux component that will revolutionise the OS. if i could get past this little hurdle

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Try to reformat the USB drive, this time don't use NTFS. If you want it to be read/write by both Linux and Windows, use FAT instead.

    CAUTION: reformatting the drive will erase all of the files on it. Don't do this if you need to recover more of the files.
    Last edited by waterhead; 04-06-2009 at 10:57 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •