Find the answer to your Linux question:
Results 1 to 6 of 6
I'm trying to use Knoppix to get into a drive that's supposed to be running Windows Vista Ultimate, but that's acquired some bad sectors and won't run chkdsk. It thinks ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    3

    [SOLVED] LiveCD 5.1.1 boot issues


    I'm trying to use Knoppix to get into a drive that's supposed to be running Windows Vista Ultimate, but that's acquired some bad sectors and won't run chkdsk. It thinks it's an unformatted drive, which isn't the case because it boots fine into safe mode, so clearly it's formatted and even has an o/s on it. But just to let you know where I'm headed -- supposedly, Knoppix should let me get it back to working condition.

    I burned a copy of 5.1.1 at 4x; all the directories and files seem to be accessible, so I think the CD is good. Trying to boot it, I've gotten a series of error messages. Here's one example, booting with options apci=off noapic, which I tried based on posts here that seemed to describe similar problems to what I've had:

    "ERROR: CANNOT UNITE READ-ONLY MEDIA AND INITIAL RAMDISK!"

    Then three times it prints "Buffer I/O error on device sr0, logical block 354567"

    And seven times it prints a two-line error message, "cloop: Read error at pos 720666572 in file /cdrom/KNOPPIX/KNOPPIX, 54341 bytes lost. [next line] cloop: zlib decompression error -3 uncompressing block 15547 131072/0/54341/0 720666572-720720913"

    Next it tells me "/linuxrc: /KNOPPIX sbin/halt: I/O error"

    And then, curiously, it says ">> Read-only CD system successfully merged with read-write /ramdisk." Wasn't that what it said it couldn't do?

    The last bits of the error info read, "/linuxrcl cannot create /var/run/utmp: directory nonexistent [next line] No filesystem could mount root, tried: reiserfs ext3 ext2 msdos vfat iso9660 fuseblk [next line] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,3)"

    I've also gotten longer strings of errors like the I/O and decompression errors, with it telling me to try passing init= to kernel. I've been trying to boot with init=3, from other posts here, and with that, I don't get the message that it can't unite the media, but I do still get a very long string of error messages; the only new element so far as I can see is "Failed to execute 3. Attempting defaults. . ." and then it comes back to telling me to try passing init= option to kernel. I assume that means init=3 didn't work, but I don't know what might.

    I'm reasonably good with computers, but I don't know enough about linux generally or Knoppix specifically to figure this out on my own. Please help!

  2. #2
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    Hello Poetiscariot, welcome to the Forums!

    As you can see, I've just joined myself, and I don't know nearly enough about Linux to tell you exactly what those errors mean, but I know about hardware, let's start with that.

    I/O as you might've guessed, means something inside the PC is not communicating properly with the other components. This can be caused on the hardware side by bad RAM (memory) sectors, not getting enough electrical power to all the components, etc. The list goes on...

    It can also be a problem on the software side. I/O means "Input/Output", and it could be that your Chipset, the Hard Drive Controller, or the DVD/CD-ROM drive is not sending information to RAM. Not because they're physically damaged, but because the device drivers are wrong, or missing.

    In short, you might need to add drivers to Knoppix, before you burn another copy.
    I'm trying to use Knoppix to get into a drive that's supposed to be running Windows Vista Ultimate, but that's acquired some bad sectors and won't run chkdsk. It thinks it's an unformatted drive, which isn't the case because it boots fine into safe mode, so clearly it's formatted and even has an o/s on it.
    What is the error chkdsk gives you? Does it simply not start?

    Have you already tried running chkdsk from the Vista install DVD? Boot from that, choose your language, then click "Repair" in the bottom left corner. If you can get it working that way, wait until you're sure chkdsk is done, (it can take up to an hour) then try System Restore from the same DVD repair menu. (you can do it from Safe Mode too, but it's not a good idea if the HDD has bad sectors...)

    If you don't have the Vista install DVD that came with the PC, then you more than likely have a Recovery Partition on the Hard drive, that more or less has the same function. When you first turn on the PC, it will tell you what key to press for Recovery. (usually F10 or F11). See what Repair options you can get from there, hopefully chkdsk is one of them.

    Back to the hardware stuff, it's possible you have a bad RAM card, pressing F8 gives you the Boot options Menu, but instead of Safe Mode, try the Windows Memory Diagnostic tool, you may have to press Tab or F10 (or both) to return to OS choices and you'll see it there.

    MemTest86+ is an even better Memory Diagnostic tool, Google that, and download the ISO file to burn a CD (on low-speed to avoid errors).

    If you have 2 or more RAM cards inside the PC, it never hurts to take one out and reboot to see if that makes any notable difference (or gets rid of the Knoppix errors) Who knows? The "bad hard drive sectors" you mention might actually be the RAM acting up all along.

    NOTE: make sure the computer is OFF and UNPLUGGED before removing the RAM. Also, these cards or RAM modules can be damaged by static, but unless you've been drying clothes recently, I wouldn't worry too much, just hold onto the metal frame of the PC with one hand, that should ground out any static you may have.

    If you haven't done so already, I strongly recommend backing up any important or irreplaceable files from this PC. You can do this from the Recovery partition or after booting the Vista DVD. Let me know if you need more details about that.

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Posts
    3
    Hello back, TechShui! All very true, and I've even used MemTest86+ before but hadn't thought of it. I don't, however, have a Vista install DVD (which would have been my first recourse) or a recovery partition on the computer in question.

    The chkdsk thing -- at first it simply wouldn't even try to run, and I had it set to run on boot. This turned out to be due to a corrupted autochk.exe, which is a problem people seem to run into occasionally after installing Windows hotfixes; I copied autochk.exe from my laptop, and it started up the very next boot. . . but it thinks the file system is RAW, i.e. that the drive is unformatted. All this happened after I picked up a couple trojans (while installing shady software, which I knew better than to do but did anyway because I'm sometimes not the world's most careful individual) and removed them. I did run Windows Update partway through that process, and my guess is that the combination of virus and/or virus-removal activity with Win Update gave me all these, er, very interesting problems to solve.

    So I'll try MemTest but I'm fairly sure the disk actually has troubles and I need to get to it with some kind of bootable CD.

    If I have to back the damn thing up I will be heartily irate because all this happened right after I migrated 200 gigs of music over to it. If people don't have guesses on how I can get Knoppix to load, then at least cross your fingers for me that *something* works.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    Not having a Recovery Partition or DVD, that complicates things. Is there anyone who can lend you a Vista install CD? A friend, a family member perhaps?

    Microsoft does offer a Windows Automated Installation Kit or WAIK on their website as a free download (yes, free). www.microsoft.com/downloads/... (Validation is required though)

    The bad news is the WAIK is 922MB (depending on your connection speed, it could take 1hr~) The good news, WAIK will allow you to create and burn to CD, a bootable Windows PE 2.0 image. (click for an article explaining more)

    This CD won't let you install Vista, but it will have CHKDSK, DISKPART, REGEDIT, TaskManager and many utilities that an actual Windows Vista install DVD would have. (plus you can customize it with more programs).

    If you can't borrow a DVD, and choose to download the WAIK, instead of wasting a DVD to burn the 922MB IMG file, use MagicDisc Virtual DVD-ROM. (Also a free download). Mount the IMG file with MagicDisc, and install the WAIK.

    Now go to Start > Programs > Microsoft Windows AIK and choose Windows PE Tools command prompt. (Right-click, then Run As Admin. if you're in Vista) Type the following, then press Enter.
    Code:
    copype x86 c:\winpe
    If done correctly, you'll now find the Windows PE 2.0 image in My Computer > (C: ) LocalDisk > WinPE. (it's about 160MB)

    Now's the time to add your Hard Disk Controller (HDC) drivers. (A controller is a microchip that sends info to your HDD) Skipping this step, could cause your hard disk drive to be undetected by Windows PE. And I have a feeling this is why chkdsk won't work on boot, and why you have corrupted or bad sectors on the drive already. Windows Update must've over-written your HDC drivers. (Google "Windows Update" and "Vista won't start", you'll see it's a common problem).

    If you give me the Model number of the PC you're having this trouble with, then I can help direct you to the correct HDC drivers. Then we'll move on to the next step.

  6. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    24
    Poetiscariot,

    It's been a while since you posted, -- Did you ever find a way to get the Knoppix CD up and running?

    Just like with the Windows PE CD, you'll want to include the Hard Drive Controller (HDC) drivers (for Linux though). That will make sure Knoppix detects your Hard drive.

    I thought Knoppix had those HDC drivers in the kernel, but if it doesn't, then that might explain why it showed an I/O error message.

  7. #6
    Just Joined!
    Join Date
    Aug 2009
    Posts
    3
    The problem turned out to be a damaged power cable on my optical drive. I fixed things with a Knoppix boot loaded onto a USB drive.

    There wasn't much to say to your previous post because my computer has no model number, because I built it, and the rest I knew how to do without needing the walkthrough. Sorry to have appeared to be ignoring you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •