Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007

    Knoppix boot problem (X won't start)

    Hello all
    I recently came into possession of an old Compaq Armada M700, 400 MHz and 400 MB RAM. I decided to try installing Knoppix on the laptop, and i used a Knoppix Live CD that i had lying around to install to the hard drive. Knoppix was working fine, and once i got wireless internet up and running, i tried an apt-get update/apt-get upgrade, which went smoothly (or so it seemed). However, on the next boot, knoppix booted to a root console. When i typed in startx (I tried it both as user and as root), I got the following error message:
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See for git access instructions.
    X.Org X Server (1.6.4 RC 1)
    Release Date: 2009-8-25
    X Protocol Version 11, Revision 0
    Build Operating System: Linux i686 Debian
    Current Operating System: Linux Microknoppix #8 SMP PREEMPT Mon Feb 9 14:33:28 CET 2009 i686
    Build Date: 14 September 2009  05:23:17PM
    xorg-server 2: ( 
    	Before reporting problems, check
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar  9 07:38:32 1980
    (==) Using config file: "/etc/X11/xorg.conf"
    (EE) Failed to load module "freetype" (module does not exist, 0)
    (EE) Failed to load module "type1" (module does not exist, 0)
    (EE) FBDEV(0): FBIOBLANK: Invalid argument
    SELinux: Disabled on system, not enabling in X server
    (EE) FBDEV(0): FBIOBLANK: Invalid argument
    xinit: ../../src/xcb_lock.c:33: _XCBUnlockDisplay: Assertion `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.
    /usr/bin/startx: line 197:  3686 Aborted                 xinit "$client" $clientargs -- "$server" $display $serverargs
    I'd really rather not reinstall on this machine; There is no way to get even a wired connection, and setting up my Broadcom wireless card was a pain, since my only way of installing packages was deb by deb using my USB key and my main laptop.
    By the way, in case this was a little unclear; i do have internet access at the moment, through my wireless network, so that might be some useful information for anyone reading this.

    I should also mention that i tried reinstalling xserver-xorg, I don't know if that would do anything but it was the only thing I could think of hehe..
    Last edited by wutcnbrowndo4u; 09-18-2009 at 05:52 AM. Reason: forgot something

  2. #2
    It says that the modules that they are trying to load (freetype and type1) is missing or accidentally deleted.
    Another is the Assertion of `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.
    The last one is /usr/bin/startx loading was aborted.

  3. #3
    Join Date
    May 2004
    arch linux
    Lots of folks install Knoppix to a hard drive, but it was never intended for that and it runs best as a liveCD, as indicated in the official Knoppix Wiki:

    Hd Install HowTo - Knoppix Documentation Wiki

    Knoppix is designed & intended to be used as a GNU/Linux LiveCD and not a HD installed Linux distro. A HD installed Knoppix will give you a running GNU/Linux system but it is not easy to support or administrate and add/remove of software is complicated and is best left to GNU/Linux experts.
    Updates and upgrades are one of the problems that users commonly run into if installed on the hard disk. For that reason, I'd recommend choosing a distribution that was designed to be installed to the hard drive.

    Either way, I hope it works out for you and that you will enjoy running Linux on your laptop.

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    Feb 2007
    Ah, i see.
    I actually hadn't come across that information; thanks for the info. Given that it's not really meant to be installed on a hard drive, I guess I can probably anticipate more problems with upgrading etc in the future, and I don't imagine those will be easy to fix on a regular basis. I think I'll try Puppy or DSL (though i gather that that is based on Knoppix, so maybe I'll stick with Puppy). Thanks very much for your response

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts